Bug 858494 - excessive logging in self-heal daemon should be reduced
excessive logging in self-heal daemon should be reduced
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Rahul Hinduja
: ZStream
Depends On: 844697 853677
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 18:30 EDT by Scott Haines
Modified: 2015-01-22 10:29 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 853677
Environment:
Last Closed: 2013-11-27 10:22:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Amar Tumballi 2013-08-01 03:14:41 EDT
need fixed in version for this, hence reopening the bug. (also this bug is targetted for 2.0.z, need to see if its actually part of 2.1.0).
Comment 4 Rahul Hinduja 2013-11-15 05:38:54 EST
Verified with the build: glusterfs-3.4.0.44rhs-1.el6rhs.x86_64

Analysed the self heal daemon log after running multiple self heal cases of more than 1L entries. 

# du -sh /var/log/glusterfs/glustershd.log 
42M	/var/log/glusterfs/glustershd.log

# ./log_analyzer.sh /var/log/glusterfs/glustershd.log 
afr_dir_exclusive_crawl:7
afr_find_child_position:3
afr_log_self_heal_completion_status:155083
afr_notify:9
afr_sh_post_nonblocking_entry_cbk:28
client3_3_entrylk_cbk:28
client3_3_inodelk_cbk:28
client_query_portmap_cbk:15
client_rpc_notify:21
client_set_lk_version_cbk:18
client_setvolume_cbk:54
gf_add_cmdline_options:6
main:1
notify:42
rpc_clnt_reconfig:18
select_server_supported_programs:18
socket_connect_finish:6
socket_init:28
__socket_rwv:6
========= Error Functions ========
afr_find_child_position:3
afr_notify:3
afr_sh_post_nonblocking_entry_cbk:28
client3_3_entrylk_cbk:28
client3_3_inodelk_cbk:28
client_query_portmap_cbk:15
socket_connect_finish:6
__socket_rwv:6

Marking it as verified. Will open new bugs when some specific logs are reported in excess.
Comment 6 errata-xmlrpc 2013-11-27 10:22:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.