Bug 858569 - Clearer usage of jbossas and ovirt-engine in setup dialogs and logs for rhevm-reports-setup and rhevm-dwh-setup
Clearer usage of jbossas and ovirt-engine in setup dialogs and logs for rhevm...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yaniv Lavi (Dary)
Jiri Belka
infra integration FailedQA
:
: 858254 (view as bug list)
Depends On:
Blocks: 857953
  Show dependency treegraph
 
Reported: 2012-09-19 03:26 EDT by Tim Hildred
Modified: 2012-12-04 13:20 EST (History)
11 users (show)

See Also:
Fixed In Version: si21
Doc Type: Bug Fix
Doc Text:
Previously when rhevm-reports and rhevm-dwh were being installed or restarted, log files and confirmation dialogs made reference to restarting jbossas. As a result, it was unclear that the jbossas service has been replaced by the ovirt-engine service. Logs and dialogs were updated to reference ovirt-engine instead of jbossas. Now, users can clearly see that the ovirt-engine service, and not the jbossas service, is stopped and re-started when installing rhevm-reports and rhevm-dwh.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:20:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Hildred 2012-09-19 03:26:06 EDT
Description of problem:
It is not clear that jbossas is no longer in use in rhev3.1

This is from the log file when attempting to install the rhevm-reports:

2012-09-19 14:52:08::DEBUG::rhevm-reports-setup::716::root:: starting main()
2012-09-19 14:52:08::DEBUG::rhevm-reports-setup::487::root:: /etc/pki/ovirt-engine/.keystore exists, ovirt-engine is installed
2012-09-19 14:52:08::DEBUG::common_utils::345::root:: checking jbossas service
2012-09-19 14:52:08::DEBUG::common_utils::333::root:: checking the status of jboss-as
2012-09-19 14:52:08::DEBUG::common_utils::295::root:: cmd = service ovirt-engine status
2012-09-19 14:52:08::DEBUG::common_utils::300::root:: output = The engine process 2652 is running.

2012-09-19 14:52:08::DEBUG::common_utils::301::root:: stderr = 
2012-09-19 14:52:08::DEBUG::common_utils::302::root:: retcode = 0
2012-09-19 14:52:08::DEBUG::common_utils::347::root:: jbossas is up and running
2012-09-19 14:52:08::DEBUG::common_utils::278::root:: asking user: Would you like to stop the JBoss service? (yes|no): 
2012-09-19 14:52:10::DEBUG::common_utils::282::root:: user answered: yes
2012-09-19 14:52:10::DEBUG::decorators::17::root:: running stopJbossService
2012-09-19 14:52:10::DEBUG::common_utils::360::root:: Stopping jboss
2012-09-19 14:52:10::DEBUG::common_utils::295::root:: cmd = service ovirt-engine stop
2012-09-19 14:52:11::DEBUG::common_utils::300::root:: output = Stopping engine-service:[60G [  [0;32mOK[0;39m  ]

We seem to use jbossas and ovirt-engine interchangeably in log files and even in the setup dialogs:
[root@rhev-manager4 ~]# ovirt-engine-dwh-setup 
In order to proceed the installer must stop the JBoss service
Would you like to stop the JBoss service? (yes|no):
Comment 2 Alon Bar-Lev 2012-09-19 03:31:43 EDT
"JBoss service" -> "Engine service"?
Comment 4 Alon Bar-Lev 2012-09-19 03:36:36 EDT
Moran, Juan,

Sync ovirt-engine as well?

INFO_START_JBOSS="Starting JBoss Service"
INFO_Q_STOP_JBOSS="Would you like to stop the JBoss service"
INFO_STOP_JBOSS="Stopping JBoss..."

/jboss/i -> engine?
Comment 5 Tim Hildred 2012-09-19 03:37:49 EDT
Alon:
Sure, whatever you can get sign-off on so that its used consistently. 

Engine service is probably better, as it gives us a bridge to the future when (maybe) all the services get renamed for rhevm.
Comment 6 Itamar Heim 2012-09-19 03:41:34 EDT
please note this covers the text shown to user as well, not only the logs.
from bug 858254:
"rhevm-dwh-setup and rhevm-reports-setup both mention stopping/starting JBoss service, should be ovirt-engine."
Comment 7 Itamar Heim 2012-09-19 03:41:40 EDT
*** Bug 858254 has been marked as a duplicate of this bug. ***
Comment 9 Juan Hernández 2012-09-19 03:49:19 EDT
(In reply to comment #4)
> Moran, Juan,
> 
> Sync ovirt-engine as well?
> 
> INFO_START_JBOSS="Starting JBoss Service"
> INFO_Q_STOP_JBOSS="Would you like to stop the JBoss service"
> INFO_STOP_JBOSS="Stopping JBoss..."
> 
> /jboss/i -> engine?

Yes, that looks good to me.
Comment 10 Alex Lourie 2012-09-20 10:40:45 EDT
Fix for engine setup posted upstream; http://gerrit.ovirt.org/#/c/8088/
Comment 13 Stephen Gordon 2012-09-27 10:24:11 EDT
Guys this is marked fixed in si19 but I have just added si19.1 and tried and still get:

# rhevm-dwh-setup 
In order to proceed the installer must stop the JBoss service
Would you like to stop the JBoss service? (yes|no): yes
Stopping Jboss...                                     [ DONE ]

# rhevm-reports-setup 
Welcome to ovirt-engine-reports setup utility
In order to proceed the installer must stop the JBoss service
Would you like to stop the JBoss service? (yes|no): yes
Stopping Jboss...                                     [ DONE ]

Versions:

# rpm -qa | grep rhevm-dwh
rhevm-dwh-3.1.0-13.el6ev.noarch

# rpm -qa | grep rhevm-reports
rhevm-reports-3.1.0-14.el6ev.noarch
Comment 14 Juan Hernández 2012-09-27 10:40:55 EDT
The packages in si19 contain the fix for engine, but not for dwh or reports. This should fix it for DWH:

http://gerrit.ovirt.org/8250
Comment 15 Stephen Gordon 2012-09-27 10:45:53 EDT
This bug was specifically raised for the issues we noticed with dwh and reports, as was the one I raised which was closed as a duplicate of this. Please ensure that they are actually fixed downstream before moving to QA.
Comment 17 Juan Hernández 2012-10-04 11:35:01 EDT
The proposed fix has been merged upstream:

http://gerrit.ovirt.org/gitweb?p=ovirt-dwh.git;a=commit;h=498f0b2a610dfa67ecce5a4c4f988dbcff149af6
Comment 22 errata-xmlrpc 2012-12-04 13:20:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1534.html

Note You need to log in before you can comment on or make changes to this bug.