Bug 858616 - pxe install error - No filename or root path specified
pxe install error - No filename or root path specified
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: etherboot (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
:
Depends On:
Blocks: 860511
  Show dependency treegraph
 
Reported: 2012-09-19 04:48 EDT by yunpingzheng
Modified: 2015-05-24 20:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 860511 (view as bug list)
Environment:
Last Closed: 2012-10-15 05:48:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pci_info (14.03 KB, application/octet-stream)
2012-09-19 04:51 EDT, yunpingzheng
no flags Details
cpu info (5.45 KB, application/octet-stream)
2012-09-19 04:52 EDT, yunpingzheng
no flags Details
e1000 (10.75 KB, image/png)
2012-09-20 06:03 EDT, yunpingzheng
no flags Details
rhel6.4-screen-dump (9.30 KB, image/png)
2012-09-20 22:46 EDT, yunpingzheng
no flags Details

  None (edit)
Description yunpingzheng 2012-09-19 04:48:16 EDT
Description of problem:
when install rhel6.3-64 on rhel5.9 using pxe,  tftp error : No filename or root path specified.

now this issue can only reproduced in the machine virtlab 
 hostname: intel-i72600-04.qe.lab.eng.nay.redhat.com 

when i run it in other machine, can not reproduced this issue.

Version-Release number of selected component (if applicable):
 kvm-83-259.el5

How reproducible:
 100%  [ in machine "intel-i72600-04.qe.lab.eng.nay.redhat.com" in virtlab ]

Steps to Reproduce:
1.reserve the machine  "intel-i72600-04.qe.lab.eng.nay.redhat.com" in virtlab
2.install rhel5.9 (tree signoff 20120910)
3.try to install rhel.6.3-64 via pxe.

  
Actual results:
can not install, tftp error  "No filename or root path specified"

Expected results:
can install 

Additional info:
host info: 
kernel: 2.6.18-339
qemu-kvm: kvm-83-259.el5

other info see attachment.

guest info:
rhel.6.3-64

using qemu command:
qemu-kvm -name 'vm1'\
-monitor unix:'/tmp/monitor-humanmonitor1-20120918-140102-pSbP',server,nowait \
-serial unix:'/tmp/serial-20120918-140102-pSbP',server,nowait \
-drive file='/root/pxe-test.qcow2',if=virtio,media=disk,cache=none,boot=off,snapshot=off,format=qcow2 \
-net nic,vlan=0,model=virtio,macaddr='9a:cd:4b:30:16:c4' \
-net tap,vlan=0,fd=28 -m 4096 -smp 4,cores=2,threads=1,sockets=2 \
-cpu 'qemu64' \
-soundhw ac97 \
-spice port=3100,ic=on,disable-ticketing -qxl 1 \
-rtc-td-hack -M rhel5.6.0 -boot n   \
-no-kvm-pit-reinjection -usbdevice tablet
Comment 1 yunpingzheng 2012-09-19 04:51:59 EDT
Created attachment 614267 [details]
pci_info
Comment 2 yunpingzheng 2012-09-19 04:52:29 EDT
Created attachment 614269 [details]
cpu info
Comment 3 Amos Kong 2012-09-20 02:29:01 EDT
<jasonwang> yunzheng, re bz858616, can reproduce in e1000? can get ip address?
Comment 4 yunpingzheng 2012-09-20 06:01:04 EDT
Amos kong jasonwang

i have retry it using e1000,rtl8130 and virtio all of them can not get ip in the host:
  "intel-i72600-04.qe.lab.eng.nay.redhat.com"

see the attachement
Comment 5 yunpingzheng 2012-09-20 06:03:16 EDT
Created attachment 614820 [details]
e1000
Comment 6 yunpingzheng 2012-09-20 22:46:31 EDT
Created attachment 615250 [details]
rhel6.4-screen-dump
Comment 7 Ronen Hod 2012-09-22 12:21:20 EDT
Postponed to 5.10 since it seems to be host specific. Probably a setup issue.
Comment 12 Amos Kong 2012-10-15 05:48:51 EDT
This bug was reported by QE (not a customer issue), and this problem only occurs in special environment (boot from pxe server which is in another subnet).

When we install guest by virsh-install, gpxe/tftp environment is established by dnsmasq, it's insider the host. This problem would not occur.

I will try to fix this issue in gpxe with RHEL6.5, and close this etherboot bug.

Note You need to log in before you can comment on or make changes to this bug.