Bug 858633 - PK should recover after yum traceback
PK should recover after yum traceback
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 05:28 EDT by Kamil Páral
Modified: 2013-11-22 05:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 05:48:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-09-19 05:28:55 EDT
Description of problem:
yum traceback currently kills PK and it doesn't work until you reboot. PK should recover itself.

[kparal@localhost ~]$ pkcon --only-download --background update
Getting updates               [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Getting information           [=========================]         
Updating packages             [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Running                       [=========================]         
Resolving dependencies        [=========================]         
Downloading packages          [=========================]         
Fatal error: Error Type: <class 'yum.Errors.RepoError'>
Error Value: Downloaded package gstreamer1-0.11.94-1.fc18.i686, from updates-testing, but it was invalid.
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3588, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3585, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.7/site-packages/packagekit/backend.py, line 760, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.7/site-packages/packagekit/backend.py, line 721, in dispatch_command
    self.update_packages(transaction_flags, package_ids)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2294, in update_packages
    self._runYumTransaction(transaction_flags, allow_skip_broken=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2378, in _runYumTransaction
    path = repo.getPackage(txmbr.po)
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 990, in getPackage
    raise Errors.RepoError, msg

[kparal@localhost ~]$ sudo rm -f /var/cache/yum/i386/18/updates-testing/packages/*
[sudo] password for kparal: 
[kparal@localhost ~]$ pkcon --only-download --background update
Getting updates               [=========================]         
Waiting in queue              [=========================]         
Starting                      [                         ] (0%)  Command failed: Failed: failed
[kparal@localhost ~]$ pkcon repo-list
Getting repositories          [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Fatal error: Failed: failed
[kparal@localhost ~]$ pkcon refresh
Refreshing cache              [=========================]         
Waiting in queue              [=========================]         
Waiting for authentication    [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Fatal error: Failed: failed
[kparal@localhost ~]$ pkcon repo-list
Getting repositories          [=========================]         
Waiting in queue              [=========================]         
Starting                      [=========================]         
Fatal error: Failed: failed


Version-Release number of selected component (if applicable):
yum-3.4.3-42.fc18.noarch
PackageKit-0.8.3-4.fc19.i686

How reproducible:
probably hard, I can't reproduce willingly

Additional info:
The traceback itself is reported as bug 858632.
Comment 1 Kamil Páral 2012-09-19 05:31:43 EDT
Here is another example that I think is related. This time yum returned a traceback that there are no more mirrors to try to retrieve a particular package. That might be caused by the fact that I replaced mirrorlist= with baseurl= in a .repo file. That could be easy to reproduce.

> [kparal@localhost ~]$ pkcon --only-download update
> Getting updates               [=========================]         
> Waiting in queue              [=========================]         
> Starting                      [=========================]         
> Getting information           [=========================]         
> Updating packages             [=========================]         
> Waiting in queue              [=========================]         
> Starting                      [=========================]         
> Running                       [=========================]         
> Resolving dependencies        [=========================]         
> Downloading packages          [=========================]         
> Fatal error: Error Type: <class 'yum.Errors.NoMoreMirrorsRepoError'>
> Error Value: failure: gstreamer1-0.11.94-1.fc18.i686.rpm from updates-testing/18/i386: [Errno 256] No more mirrors to try.
> [kparal@localhost ~]$ pkcon repo-list
> Getting repositories          [=========================]         
> Waiting in queue              [=========================]         
> Starting                      [=========================]         
> Fatal error: Failed: failed
> [kparal@localhost ~]$ sudo vi /etc/yum.repos.d/fedora-updates-testing.repo 
> [sudo] password for kparal: 
> #### I've put back mirrorlist= in here, instead of baseurl= ####
> [kparal@localhost ~]$ pkcon repo-list
> Getting repositories          [=========================]         
> Waiting in queue              [=========================]         
> Starting                      [=========================]         
> Fatal error: Failed: failed
> [kparal@localhost ~]$ pkcon refresh
> Refreshing cache              [=========================]         
> Waiting in queue              [=========================]         
> Waiting for authentication    [=========================]         
> Waiting in queue              [=========================]         
> Starting                      [=========================]         
> Fatal error: Failed: failed
> [kparal@localhost ~]$ pkcon refresh --force
> Failed to parse command line: Unknown option --force
Comment 2 Richard Hughes 2013-11-22 05:48:06 EST
I don't think this is possible in Fedora 19 or Fedora 20. Please open if you can reproduce with a new backtrace. Thanks.

Note You need to log in before you can comment on or make changes to this bug.