Bug 858651 - Network can be set by DHCP successfully, even with no IPv4 Settings is selected.
Network can be set by DHCP successfully, even with no IPv4 Settings is selected.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On: 867784
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 06:19 EDT by Meng Liang
Modified: 2016-04-26 12:02 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Previously, in the case where no IPv4 settings had been entered in the Hypervisor's TUI Network configuration screen, hitting apply led the network to be configured using DHCP. Now, the network can only be configured if one of the boot protocols has been selected, instead of defaulting to DHCP. Users who attempt to apply an invalid network configuration will be prompted to select a valid boot protocol.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:39:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message (20.61 KB, image/png)
2012-10-23 06:14 EDT, Fabian Deutsch
no flags Details

  None (edit)
Description Meng Liang 2012-09-19 06:19:34 EDT
Description of problem:
Network can be set by DHCP successfully, even with no IPv4 Settings is selected.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120913.0.el6_3

How reproducible:
Always
QA Whiteboard: Network

Steps to Reproduce:
1. install rhev-hypervisor6-6.3-20120913.0.el6_3
2. Go to Network Detail page, configure as:
    IPv4 Settings
    [ ] Disabled [ ] DHCP [ ]Static
    IP Address: _______Netmask:______
    Gateway: _______
3. Press <Apply>

Actual results:
The network was set by DHCP successfully. Go to network detail page, it shows:
    IPv4 Settings
    [ ] Disabled [*] DHCP [ ]Static

Expected results:
Network setting should be fail with a error message to notice invalid input. Then lead the user back to a fresh new network detail page.

Additional info:
Comment 3 Fabian Deutsch 2012-09-27 09:02:37 EDT
Upstream patch:

http://gerrit.ovirt.org/#/c/8215/

Prompts the user to choose a "boot protocol" option. Maybe the sentence can be rephrased.

Tested as follows:
1. Install recent rhevh
2. Apply patch
3. Enter NICs detail page and configure one NIC using dhcp
4. Re-enter NICs detail page and unselect DHCP (neither disabled, dhcp or static are checked now)
5. Select <apply>
6. Confirm "configuration changed dialog"
= Dialog appears and asks the user to select one appropriate boot protocol.
Comment 5 Meng Liang 2012-10-23 04:46:53 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
Test steps:
1. install rhev-hypervisor6-6.3-20120913.0.el6_3
2. Go to Network Detail page, configure as:
    IPv4 Settings
    [ ] Disabled [ ] DHCP [ ]Static

Test Result:
Network setting should be fail with the error message 'Please Input: - IPv4 boot protocol(Disabled, Static, DHCP)'
However, pressed 'ok', the page will be lead to network detail page on which there is a * at Static option:
    IPv4 Settings
    [ ] Disabled [ ] DHCP [*]Static

Then refresh the page, it displays correctly.
Comment 6 Fabian Deutsch 2012-10-23 06:14:20 EDT
I can not reproduce this.

The TUI behaves as expected for me with rhevh-6.4-20121015.1

1. install rhevh-6.4-20121015.1
2. Go to Network Detail page, configure as:
    IPv4 Settings
    [ ] Disabled [ ] DHCP [ ]Static

Test Result:
Network setting displays the message 'Please Input: - IPv4 boot protocol(Disabled, Static, DHCP)' (after confirming to apply the network settings with 'OK')

Meng,
could you try to reproduce this again with the version above and otherwise could you provide /var/log/ovirt.log?
Comment 7 Fabian Deutsch 2012-10-23 06:14:50 EDT
Created attachment 632011 [details]
error message
Comment 8 Meng Liang 2012-10-24 02:05:18 EDT
(In reply to comment #6)
> I can not reproduce this.
> 
> The TUI behaves as expected for me with rhevh-6.4-20121015.1
> 
> 1. install rhevh-6.4-20121015.1
> 2. Go to Network Detail page, configure as:
>     IPv4 Settings
>     [ ] Disabled [ ] DHCP [ ]Static
> 
> Test Result:
> Network setting displays the message 'Please Input: - IPv4 boot
> protocol(Disabled, Static, DHCP)' (after confirming to apply the network
> settings with 'OK')
> 
> Meng,
> could you try to reproduce this again with the version above and otherwise
> could you provide /var/log/ovirt.log?

I can reproduce this. 

/var/log/ovirt.log:

2012-10-24 06:01:11,680 - DEBUG - ovirt-config-setup - Current Page: 19
2012-10-24 06:01:11,692 - DEBUG - ovirtfunctions - unable to determine ip/netmask from: 
2012-10-24 06:01:11,695 - DEBUG - ovirtfunctions - unable to determine ip/netmask from: 
2012-10-24 06:01:11,704 - DEBUG - ovirtfunctions - unable to determine ip/netmask from: 
2012-10-24 06:01:16,864 - DEBUG - ovirt-config-setup - Current Page: 19
2012-10-24 06:01:16,875 - DEBUG - ovirtfunctions - unable to determine ip/netmask from: 
2012-10-24 06:01:16,878 - DEBUG - ovirtfunctions - unable to determine ip/netmask from: 
2012-10-24 06:01:16,886 - DEBUG - ovirtfunctions - unable to determine ip/netmask from:
Comment 11 Fabian Deutsch 2012-10-25 04:02:21 EDT
I had some trouble finding what the problem is, but now I found it. Fix is in the works.
Comment 13 Fabian Deutsch 2012-10-25 06:28:53 EDT
http://gerrit.ovirt.org/#/c/8809/

Test is pending. Note that this bug depends on bug #867784 , otherwise you can test the case where it is set to static (will always jump back to dhcp, as static can not be configured, see bug)
Comment 14 Fabian Deutsch 2012-10-25 09:20:50 EDT
Tested as follows (with this patch and patch from #867784):

1. Install RHEVH
2. Select NIC
3. Deselect "Disabled" and press apply
4. Message about missing bootprotocol appears, "Disabled" is selected
5. Select "DHCP" and press apply
6. Re-enter NIC details
7. Deselect "DHCP" and press apply
8. Message about missing bootprotocol appears, "DHCP" is selected
9. Select "static" and press apply
10. Re-enter NIC details
11. Deselect "static and press apply
12. Message about missing bootprotocol appears, "static" is selected
Comment 20 errata-xmlrpc 2013-02-28 11:39:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.