Bug 858681 - NTP servers disappear when shown twice
NTP servers disappear when shown twice
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 08:15 EDT by Stef Walter
Modified: 2012-11-22 21:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:20:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2012-09-19 08:15:02 EDT
Description of problem:

When I click the gears next to 'Network Time OFF', a set of NTP servers is shown. If I press cancel, and then click the gears again, the NTP servers have been cleared.

Version-Release number of selected component (if applicable):

Fedora 18-Alpha
Comment 1 Vratislav Podzimek 2012-09-20 06:48:07 EDT
I'm sorry, but I cannot reproduce it. Could you please attach logs from such case and describe, how you can reproduce it step by step? Does it happen on live installation?
Comment 2 Vratislav Podzimek 2012-09-20 07:11:32 EDT
Okay, I've successfully reproduced this issue. It happens when you click on OK button of the NTPServers dialog and then in a short time click the gears again.
Comment 3 Vratislav Podzimek 2012-09-20 07:21:33 EDT
(In reply to comment #2)
> Okay, I've successfully reproduced this issue. It happens when you click on
> OK button of the NTPServers dialog and then in a short time click the gears
> again.
This is not enough. One has to click OK, in a short time click the gears again, click Cancel and click gears again. OK button saves servers to the configuration file and Cancel causes that this file is read. I have no idea why, but this obviously leads to an empty configuration file and thus no servers in the list.
Comment 4 Vratislav Podzimek 2012-09-20 07:54:12 EDT
To continue my monologue...
Problem is in saving NTP servers to the configuration file, which leads in an empty file. Fix posted to anaconda-patches list.
Comment 5 Vratislav Podzimek 2012-09-20 07:59:02 EDT
No additional info needed.
Comment 6 Vratislav Podzimek 2012-09-21 07:20:39 EDT
(In reply to comment #4)
> To continue my monologue...
> Problem is in saving NTP servers to the configuration file, which leads in
> an empty file. Fix posted to anaconda-patches list.
Pushed to master.
Comment 7 Adam Williamson 2012-11-22 21:20:59 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.