Bug 858696 - virt-sysprep reports Guestfs.Error("read_lines: fopen: /etc/sysconfig/network: No such file or directory") on some Fedora guests
virt-sysprep reports Guestfs.Error("read_lines: fopen: /etc/sysconfig/network...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 08:49 EDT by Richard W.M. Jones
Modified: 2012-11-30 07:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 07:44:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-09-19 08:49:23 EDT
Description of problem:

If you install a Fedora 18 guest using the new anaconda, then
/etc/sysconfig/network is not always created.  I don't know why
this doesn't happen -- possibly because the text based installer
doesn't set the hostname?  Anyway, this breaks virt-sysprep:

# virt-sysprep -d F18Alpha
sysprep operation failed: exception: Guestfs.Error("read_lines: fopen: /etc/sysconfig/network: No such file or directory")

Version-Release number of selected component (if applicable):

libguestfs 1.18, also probably occurs in development branch

How reproducible:

100%

Steps to Reproduce:
1. Install Fedora 18 alpha using text installer.
2. Run virt-sysprep on it.

Actual results:

Fails as above.
Comment 2 Richard W.M. Jones 2012-11-30 07:27:00 EST
Reopening.

It turns out this is broken because of:
https://fedorahosted.org/fesco/ticket/963
(read that ticket and weep).

I'm going to fix this by setting /etc/hostname if the
version of Fedora detected is >= 18.

Note You need to log in before you can comment on or make changes to this bug.