Bug 85878 - kudzu totally screwing things up
kudzu totally screwing things up
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-10 00:35 EST by Martin DiViaio
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-31 12:20:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin DiViaio 2003-03-10 00:35:44 EST
I recently upgraded to version 0.99.42.2.72 based on a recomendation from up2date. When my system was rebooted, kudzu kicked in.

It first decided that my mouse configration was wrong and added a "DEVICE=/dev/mouse" line to /etc/sysconfig/mouse. This completely screwed up just about every program that reads this file since not a single one understands that line.

Not satisified with that, it then decided that my XF86Config file didn't properly understand my mouse. It removed the InputDevice line from the file and replaced it with a Device line. This change, made X crash at startup with an error saying it couldn't find the mouse.

To top it all off, kudzu then decided that I was booting into the wrong runlevel. It changed my runlevel to 5 in the /etc/inittab file. It also decided that I needed to run xinetd and lpd and activated them to start at boot time.

While I can understand the first two changes, a little warning that they were being made would have been appreciated. I won't discuss the fact that they were wrong. The third set of changes were completely uncalled for. kudzu, being a hardware manager had absolutely no business playing around with my system configurations.

Keep in mind, I've spent nearly two days checking all of my system configurations to make sure that kudzu didn't do any more damage than listed here. I've found a few other minor irritations but nothing as potentially disasterous as what is listed above. It was shear luck that I had previously run into a situation where X wouldn't start in runlevel 5 that I knew what to do.
Comment 1 Bill Nottingham 2003-03-10 16:34:20 EST
kudzu does not touch xinetd or lpd.

As for the mouse, kudzu simply calls mouseconfig.
Comment 2 Brent Fox 2003-03-31 12:20:54 EST
We have replaced mouseconfig with redhat-config-mouse.  If you see this behavior
with redhat-config-mouse-1.0.5-1 or later, please reopen this bug report.

Note You need to log in before you can comment on or make changes to this bug.