Bug 85886 - 2.17 schema not compatible with 2.15 running on rhdb 2.1
2.17 schema not compatible with 2.15 running on rhdb 2.1
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-10 05:01 EST by sand
Modified: 2013-06-23 23:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 17:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sand 2003-03-10 05:01:36 EST
Description of problem: 2.17 schema not compatible with 2.15 running on rhdb 2.1

Version-Release number of selected component (if applicable): 2.17

How reproducible: Only have done it once (see below).

Steps to Reproduce:
1. Install rh pro 8.0.
2. Install rhdb 2.1.
3. Install rh bugzilla 2.15
4. Enter some bugs.
5. Install rh bugzilla 2.17
6. Run pgsetup.pl
7. Try to enter or view bugs.
    
Actual results: Errors are thrown by the SQL code because of missing id for such tables as components, products, etc.

My analysis: rhdb 2.1 basically is postgresql 7.2.3 and I need 7.3 in order to add such things as a "serial primary key." They can only be applied to a not null int, which can't be added directly, can't be altered from a plain int, since you can't alter it "set not null." So, I am about to uninstall rhdb 2.1 and install postgres 7.3. To see if I can hammer the schema into line.

Expected results: Would have preferred that pgsetup.pl had worked. Perhaps it will when I install postgresql 7.3 rpm's.


Additional info:
Comment 1 sand 2003-06-04 14:05:23 EDT
I'm currently running version 2.17.1. To accomplish this, I (a) upgraded to
postgresql 7.3.2, (b) added new tables to the bugs database, (c) altered half a
dozen existing ones (adding columns and altering values), (d) added expanded
permissions to several tables and sequences. This process took several hours.

I would have preferred that pgsetup.pl have done all of this upgrading for me.
If you like, if it will aid in improving pgsetup, I can email you some of the
queries I used in (c) and (d). Let me know.
Comment 2 David Lawrence 2006-04-08 13:44:16 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.

Note You need to log in before you can comment on or make changes to this bug.