This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 858904 - Desktop environment selection deselects add-ons.
Desktop environment selection deselects add-ons.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 20:42 EDT by William Brown
Modified: 2012-11-22 21:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:28:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Brown 2012-09-19 20:42:07 EDT
Description of problem:
In anaconda, in the "software selection" menu, you are able to select an "environment" for your desktop or system, and are then able to select addons. 

When add ons are selected, and the desktop enivronment is changed, the add ons that were selected, are unchecked. 

How reproducible:
Always

Steps to Reproduce:
1. Software selection. Select a desktop environment.
2. Select some set of add ons.
3. Select a different desktop enivronment. 
  
Actual results:
Add ons are unselected. 

Expected results:
Add ons stay selected.
Comment 1 Chris Lumens 2012-09-25 11:35:24 EDT
With anaconda-18.8 (post-alpha), I'm not really seeing this.  As a test, I've selected the GNOME Desktop environment and the Admin Tools, Applications for GNOME, and A & P add-ons.  I then select the KDE Desktop environment.  Admin Tools and A & P are still selected.  The Applications for GNOME group is unselected, because it's no applicable to the selected environment.

This seems like sensible behavior to me.  Does it line up with what you are seeing?
Comment 2 William Brown 2012-09-28 20:20:54 EDT
No. In what I was seeing, everything was deselected instead.

However, I'm not sure how to test a "post-alpha" version of this. I'm happy to take your word that it is fixed, and I'll just keep in mind to test this in a later alpha / beta release.
Comment 3 William Brown 2012-10-17 08:47:22 EDT
Still present in Beta-TC4 x86_64

Select Gnome desktop
Select Administration Tools
Select KDE desktop

Administration tools is deselected.
Comment 4 Adam Williamson 2012-11-22 21:28:10 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(tested, cannot reproduce with Beta RC1, appears to work fine, as clumens describes.)

Note You need to log in before you can comment on or make changes to this bug.