Bug 858965 - Target Milestones are not sorted correctly
Target Milestones are not sorted correctly
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 04:15 EDT by Raymond Mancy
Modified: 2014-10-12 18:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 07:12:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2012-09-20 04:15:27 EDT
Description of problem:

The Target milestones select field is not sorted correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Search for a Bug in beaker
2. Look at the Target Milestones after refreshing them
3.
  
Actual results:

0.10 comes before 0.6.1 etc etc

Expected results:

0.10 should be at the end

Additional info:
Comment 2 Raymond Mancy 2012-09-20 08:05:46 EDT
Are they not sorted ascending by default?

If so, it looks like a bug in the algorithm that thinks that 0.10.0 < 0.6.0
Comment 3 Simon Green 2012-09-20 16:51:52 EDT
(In reply to comment #2)
> Are they not sorted ascending by default?
> 
> If so, it looks like a bug in the algorithm that thinks that 0.10.0 < 0.6.0

Assuming the sort key is the same, they are sorted as a string by default (which explains why 0.10 < 0.6)

  -- simon
Comment 4 Raymond Mancy 2012-09-20 16:58:29 EDT
OK. Surely the _intent_ is to sort by ascending versions though yeah?
(at least for those strings that represent numbers, I realise there are some strings in there like 'future_maint' etc)
Comment 5 Simon Green 2012-09-20 17:13:48 EDT
(In reply to comment #4)
> OK. Surely the _intent_ is to sort by ascending versions though yeah?
> (at least for those strings that represent numbers, I realise there are some
> strings in there like 'future_maint' etc)

Nice to have, but MySQL doesn't support natural sorting, so I cannot see it happening. We have a sortkey on the table which is the correct solution around it.
Comment 6 Raymond Mancy 2012-09-20 17:39:07 EDT
Right, you would have to do it in bugzilla. Other apps can do it.
So manually sorting for every set of target milestones where it's not done correctly is the correct solution?

At least close it WONTFIX, rather than NOTABUG, as it clearly is a bug.

Note You need to log in before you can comment on or make changes to this bug.