Bug 859020 - s-c-kdump should be able to set crashkernel=auto option.
s-c-kdump should be able to set crashkernel=auto option.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Milata
Petr Beňas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 07:39 EDT by Roman Rakus
Modified: 2015-01-04 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version: system-config-kdump-2.0.10-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:48:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2012-09-20 07:39:58 EDT
Description of problem:
s-c-kdump should be able to set crashkernel=auto option. The same way like in RHEL6.
Comment 1 Bill Nottingham 2012-10-19 16:32:14 EDT
Is this where we're intending this feature to live for this release, and we're intending for 'auto' to be the proper setting for the forseeable future?
Comment 2 Roman Rakus 2012-10-24 07:40:47 EDT
I have discussed it with kexec-tools guys and 'auto' option is valid for RHEL 7.
Comment 3 Roman Rakus 2012-11-28 11:21:47 EST
Fixed in system-config-kdump-2.0.10-2.el7
Comment 6 Petr Beňas 2013-06-17 07:31:39 EDT
Reproduced in system-config-kdump-2.0.9-1.el7 and verified in system-config-kdump-2.0.10-2.el7.
Comment 9 Morgan Leijström 2014-06-02 09:16:14 EDT
I tried and it worked to have set crashkernel=auto in grub.cfg, but i saw in var/log messages: "crashkernel: memory value expected" so either everything is not 100% ok, or that message should not be generated.
Also, system-config-kdump crash if crashkernel=auto in grub.cfg !
fc20 64 bit last month.
Comment 10 Ludek Smid 2014-06-13 05:48:32 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.