Bug 859023 - image building for rhevm/vsphere and pushing for ec2 is failing
image building for rhevm/vsphere and pushing for ec2 is failing
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.1.0
x86_64 Linux
urgent Severity high
: beta2
: ---
Assigned To: Ian McLeod
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 07:48 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-28 08:07:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image factory logs (651.14 KB, text/x-log)
2012-09-20 07:48 EDT, pushpesh sharma
no flags Details
build_push_fails (98.67 KB, image/png)
2012-09-20 07:50 EDT, pushpesh sharma
no flags Details
buil_push_success_for_rhevm (102.34 KB, image/png)
2012-09-20 07:51 EDT, pushpesh sharma
no flags Details

  None (edit)
Description pushpesh sharma 2012-09-20 07:48:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Used folloing two templates for image build/push both are failing 


[psharma@dhcp193-66 ~]$ cat /home/psharma/RHEL6.2_Template.xml
<?xml version="1.0" encoding="UTF-8"?>
<template>
<name>RHEL6-2</name>
<description>A Red Hat Enterprise Linux 6.2 image</description>
<os>
<rootpw>password</rootpw>
<name>RHEL-6</name>
<version>2</version>
<arch>x86_64</arch>
<install type="url">
<url>http://download.eng.pnq.redhat.com/pub/rhel/released/RHEL-6/6.2/Server/x86_64/os</url>
</install>
</os>
</template>


[psharma@dhcp193-66 ~]$ cat /home/psharma/fedora15_temp.xml
<?xml version="1.0"?>
  <template>
      <name>Fedora 15</name>
      <description>desc</description>
      <os>
        <rootpw>password</rootpw>
        <name>Fedora</name>
        <arch>x86_64</arch>
        <version>15</version>
        <install type="url">
          <url>http://download.fedoraproject.org/pub/fedora/linux/releases/15/Fedora/x86_64/os/</url>
        </install>
      </os>
      <repositories>
        <repository name="custom">
          <url>http://repos.fedorapeople.org/repos/aeolus/demo/webapp/</url>
          <signed>false</signed>
        </repository>
      </repositories>
  </template> 
The behaviour seems intermitent.It failed to build rhel6.2 for rhevm but build the image of fed15 on same rhevm host for which it was complaining for "kvm not supported".  
PFA for complete image factory logs .

I am using these templates since ages, so i dont feel there is problem with that. Here is what imagesfactory logs says :-


temporary security group (imagefactory-3506defc-e6f6-424e-b266-0c3d01966699)
2012-09-20 23:43:09,476 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder thread(3506defc) Message: Exception caught in ImageFactory
2012-09-20 23:43:09,476 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder thread(3506defc) Message: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 458, in push_image
    credentials)
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 665, in push_image_snapshot_ec2
    self.guest.do_customize(guestaddr)
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 1110, in do_customize
    tunnels=self.tunnels)
  File "/usr/lib/python2.6/site-packages/imgfac/builders/RHEL6_ec2_Builder.py", line 31, in guest_execute_command
    return super(RHEL6RemoteGuest, self).guest_execute_command(guestaddr, command, timeout, tunnels)
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 476, in guest_execute_command
    command, timeout, tunnels)
  File "/usr/lib/python2.6/site-packages/oz/ozutil.py", line 355, in ssh_execute_command
    return subprocess_check_output(cmd)
  File "/usr/lib/python2.6/site-packages/oz/ozutil.py", line 323, in subprocess_check_output
    raise SubprocessException("'%s' failed(%d): %s" % (cmd, retcode, stderr), retcode)
SubprocessException: 'ssh -i /tmp/tmpe2OJZK -F /dev/null -o ServerAliveInterval=30 -o StrictHostKeyChecking=no -o ConnectTimeout=30 -o UserKnownHostsFile=/dev/null -o PasswordAuthentication=no root@ec2-54-251-1-116.ap-southeast-1.compute.amazonaws.com yum -y install "aeolus-audrey-agent" ' failed(1): Warning: Permanently added 'ec2-54-251-1-116.ap-southeast-1.compute.amazonaws.com,54.251.1.116' (RSA) to the list of known hosts.
Error: Nothing to do


2012-09-20 23:43:09,476 DEBUG imgfac.BuildJob.BuildJob thread(3506defc) Message: Builder (3506defc-e6f6-424e-b266-0c3d01966699) changed status from PUSHING to FAILED
2012-09-20 23:43:09,477 DEBUG imgfac.BuildJob.BuildJob thread(3506defc) Message: 3506defc-e6f6-424e-b266-0c3d01966699 for ec2 about to exit ec2 queue...
2012-09-20 23:43:09,477 DEBUG imgfac.ReservationMan



012-09-17 22:43:00,954 DEBUG imgfac.builders.BaseBuilder.RHEL6_rhevm_Builder thread(88f9cbd4) Message: Found neither a call-time config nor a config file - doing nothing
2012-09-17 22:43:00,975 DEBUG oz.Guest.RHEL6Guest thread(88f9cbd4) Message: libvirt bridge name is virbr0
2012-09-17 22:43:00,976 DEBUG imgfac.builders.BaseBuilder.RHEL6_rhevm_Builder thread(88f9cbd4) Message: Exception caught in ImageFactory
2012-09-17 22:43:00,977 DEBUG imgfac.builders.BaseBuilder.RHEL6_rhevm_Builder thread(88f9cbd4) Message: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_rhevm_Builder.py", line 66, in build_image
    self.build_upload(build_id)
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_rhevm_Builder.py", line 93, in build_upload
    guest = oz.GuestFactory.guest_factory(self.tdlobj, oz_config, None)
  File "/usr/lib/python2.6/site-packages/oz/GuestFactory.py", line 69, in guest_factory
    klass = oz.RHEL_6.get_class(tdl, config, auto, output_disk)
  File "/usr/lib/python2.6/site-packages/oz/RHEL_6.py", line 57, in get_class
    return RHEL6Guest(tdl, config, auto, output_disk)
  File "/usr/lib/python2.6/site-packages/oz/RHEL_6.py", line 35, in __init__
    "cpio")
  File "/usr/lib/python2.6/site-packages/oz/RedHat.py", line 42, in __init__
    None, None, diskbus, iso_allowed, url_allowed)
  File "/usr/lib/python2.6/site-packages/oz/Guest.py", line 1181, in __init__
    mousetype, diskbus, iso_allowed, url_allowed)
  File "/usr/lib/python2.6/site-packages/oz/Guest.py", line 179, in __init__
    self.connect_to_libvirt()
  File "/usr/lib/python2.6/site-packages/oz/Guest.py", line 122, in connect_to_libvirt
    self._discover_libvirt_type()
  File "/usr/lib/python2.6/site-packages/oz/Guest.py", line 74, in _discover_libvirt_type
Comment 1 pushpesh sharma 2012-09-20 07:48:57 EDT
Created attachment 614858 [details]
image factory logs
Comment 2 pushpesh sharma 2012-09-20 07:50:19 EDT
Created attachment 614859 [details]
build_push_fails
Comment 3 pushpesh sharma 2012-09-20 07:51:00 EDT
Created attachment 614860 [details]
buil_push_success_for_rhevm
Comment 6 pushpesh sharma 2012-09-26 08:26:12 EDT
As I already mentioned in description the bug is intermittent in behaviour.I reported the bug with logs,that is what most information I have.I also tried it again but failed to reproduce.My image factory version is             imagefactory-1.0.2-1.el6cf.noarch,So i dont think it is a problem.If somebody can peek into logs attached and find what was the root cause that will be great, else i am happy with closing this bug as i am not able to reproduce it now.
Comment 7 pushpesh sharma 2012-09-28 08:07:27 EDT
No more reproducable. So closing for now.

Note You need to log in before you can comment on or make changes to this bug.