Bug 859059 - Qpid_JCA_Adapter_User_Guide - Qpid JCA property names changed
Qpid_JCA_Adapter_User_Guide - Qpid JCA property names changed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Installation_and_Configuration_Guide (Show other bugs)
2.2
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Joshua Wulf
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 09:35 EDT by ppecka
Modified: 2015-09-27 22:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:06:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ppecka 2012-09-20 09:35:07 EDT
Description of problem:
Change occured mainly in config property names. This was minor change to comply with JCA spec.
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/2/html/Qpid_JCA_Adapter_User_Guide/sect-Qpid_JCA_Adapter_User_Guide-Configuration_JBoss-Administered_Object.html
Here is what have changed:

sessionDefaultType -> SessionDefaultType

useTryLock -> UseTryLock

ClientID -> ClientId

destinationType -> DestinationAddress

connectionURL -> ConnectionURL

javax.jms.Destination -> org.apache.qpid.ra.admin.QpidQueue

org.apache.qpid.ra.admin.QpidDestinationProxy -> org.apache.qpid.ra.admin.QpidQueueImpl



Version-Release number of selected component (if applicable):

here is full diff  mrg2.1.2 vs mrg2.2.0 ra.xml
72c72
<       <description>Interval between setup attempts</description>
---
>       <description>Interval between setup attempts in milliseconds</description>
107c107
<       <description>connection URL</description>
---
>       <description>Connection URL</description>
110c110,117
<       <config-property-value>amqp://guest:guest@/test?brokerlist='tcp://localhost:5672'</config-property-value>
---
>       <config-property-value>amqp://anonymous:passwd@client/test?brokerlist='tcp://localhost?sasl_mechs='PLAIN''</config-property-value>
>     </config-property>
>     
>     <config-property>
>       <description>Use a JMS Connection per MessageHandler</description>
>       <config-property-name>UseConnectionPerHandler</config-property-name>
>       <config-property-type>java.lang.Boolean</config-property-type>
>       <config-property-value>true</config-property-value>
119c126
<           <config-property-name>sessionDefaultType</config-property-name>
---
>           <config-property-name>SessionDefaultType</config-property-name>
126c133
<           <config-property-name>useTryLock</config-property-name>
---
>           <config-property-name>UseTryLock</config-property-name>
140c147
<           <config-property-name>ClientID</config-property-name>
---
>           <config-property-name>ClientId</config-property-name>
198d204
< 
200,201c206,207
<             <adminobject-interface>javax.jms.Destination</adminobject-interface>
<             <adminobject-class> org.apache.qpid.ra.admin.QpidDestinationProxy</adminobject-class>
---
>             <adminobject-interface>org.apache.qpid.ra.admin.QpidQueue</adminobject-interface>
>             <adminobject-class> org.apache.qpid.ra.admin.QpidQueueImpl</adminobject-class>
203c209
<                 <config-property-name>destinationAddress </config-property-name>
---
>                 <config-property-name>DestinationAddress </config-property-name>
205a212,215
>         </adminobject>
>       <adminobject>
>             <adminobject-interface>org.apache.qpid.ra.admin.QpidTopic</adminobject-interface>
>             <adminobject-class> org.apache.qpid.ra.admin.QpidTopicImpl</adminobject-class>
207c217
<                 <config-property-name>destinationType</config-property-name>
---
>                 <config-property-name>DestinationAddress </config-property-name>
215,216c225,226
<                 <config-property-name>connectionURL</config-property-name>
<                 <config-property-type>java.lang.String </config-property-type>
---
>                 <config-property-name>ConnectionURL</config-property-name>
>                 <config-property-type>java.lang.String</config-property-type>
Comment 1 ppecka 2012-09-21 09:17:17 EDT
weston, can you please review and give confirmation to this BZ?
Comment 2 Weston M. Price 2012-09-21 09:32:01 EDT
The property name changes will not cause issues as all JCA 1.5 compliant application servers ignore case in property names. 

The destination changes were required and have been documented in the JCA documentation.
Comment 3 Weston M. Price 2012-09-21 09:34:28 EDT
I stand corrected, this is indeed a change and due to a bug in JBoss EAP, this will cause issues. I am reviewing the documentation now.
Comment 8 Weston M. Price 2012-12-05 10:10:56 EST
Ok, sorry it has taken so long but looking at the README-x docs they do need to be updated to reflect the property names changes. I am doing this now.
Comment 9 Weston M. Price 2012-12-12 05:34:31 EST
I have a patch that modifies the JBOSS-README.txt file to reflect the property name changes. All other README files are correct and do not require any modification.
Comment 10 Joshua Wulf 2013-01-07 01:23:52 EST
Should this task be closed now?

It's open against the Installation and Configuration Guide, but it sounds like the issue affects README files only.
Comment 11 Weston M. Price 2013-01-07 06:32:04 EST
Yep, let's go ahead and close it.

Note You need to log in before you can comment on or make changes to this bug.