Bug 859187 - yum fails with "transaction check vs depsolve" error
yum fails with "transaction check vs depsolve" error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 14:35 EDT by Jim Jones
Modified: 2014-05-28 08:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-28 08:38:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Jones 2012-09-20 14:35:42 EDT
Description of problem:

Running "yum update" fails in "Running Transaction Check" phase.  I've attached a partial console log with specific info displayed below.

Version-Release number of selected component (if applicable):


How reproducible:

At the moment, completely reproducible since "yum" exits without changing the system.  But the specific set of packages installed is required to reproduce the problem.

Steps to Reproduce:
1. run "yum update"
  
Actual results:

[root@aqui ~]# yum update
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package automake.noarch 0:1.11.3-1.fc17 will be updated
---> Package automake.noarch 0:1.11.6-1.fc17 will be an update
---> Package cinnamon.x86_64 0:1.5.2-6.fc17 will be updated
---> Package cinnamon.x86_64 0:1.6.0-1.fc17 will be an update
--> Processing Dependency: python-lxml for package: cinnamon-1.6.0-1.fc17.x86_64
---> Package desktop-file-utils.x86_64 0:0.19-6.fc17 will be updated
---> Package desktop-file-utils.x86_64 0:0.20-4.fc17 will be an update
---> Package evolution-data-server.x86_64 0:3.4.4-2.fc17 will be updated
---> Package evolution-data-server.x86_64 0:3.4.4-3.fc17 will be an update
---> Package irqbalance.x86_64 2:1.0.3-4.fc17 will be updated
---> Package irqbalance.x86_64 2:1.0.3-6.fc17 will be an update
---> Package muffin.x86_64 0:1.0.6-2.fc17 will be updated
---> Package muffin.x86_64 0:1.1.0-1.fc17 will be an update
---> Package openconnect.x86_64 0:4.06-1.fc17 will be updated
---> Package openconnect.x86_64 0:4.07-1.fc17 will be an update
---> Package paps.x86_64 0:0.6.8-18.fc17 will be updated
---> Package paps.x86_64 0:0.6.8-20.fc17 will be an update
---> Package paps-libs.x86_64 0:0.6.8-18.fc17 will be updated
---> Package paps-libs.x86_64 0:0.6.8-20.fc17 will be an update
---> Package ruby.x86_64 0:1.9.3.194-15.fc17 will be updated
---> Package ruby.x86_64 0:1.9.3.194-16.fc17 will be an update
---> Package ruby-irb.noarch 0:1.9.3.194-15.fc17 will be updated
---> Package ruby-irb.noarch 0:1.9.3.194-16.fc17 will be an update
---> Package ruby-libs.x86_64 0:1.9.3.194-15.fc17 will be updated
---> Package ruby-libs.x86_64 0:1.9.3.194-16.fc17 will be an update
---> Package rubygem-bigdecimal.x86_64 0:1.1.0-15.fc17 will be updated
---> Package rubygem-bigdecimal.x86_64 0:1.1.0-16.fc17 will be an update
---> Package rubygem-io-console.x86_64 0:0.3-15.fc17 will be updated
---> Package rubygem-io-console.x86_64 0:0.3-16.fc17 will be an update
---> Package rubygem-rdoc.noarch 0:3.12-3.fc17 will be updated
---> Package rubygem-rdoc.noarch 0:3.12-4.fc17 will be an update
---> Package vlgothic-fonts.noarch 0:20120629-1.fc17 will be updated
---> Package vlgothic-fonts.noarch 0:20120905-1.fc17 will be an update
---> Package vlgothic-fonts-common.noarch 0:20120629-1.fc17 will be updated
---> Package vlgothic-fonts-common.noarch 0:20120905-1.fc17 will be an update
---> Package vlgothic-p-fonts.noarch 0:20120629-1.fc17 will be updated
---> Package vlgothic-p-fonts.noarch 0:20120905-1.fc17 will be an update
---> Package webkitgtk.x86_64 0:1.8.1-2.fc17 will be updated
---> Package webkitgtk.x86_64 0:1.8.3-1.fc17 will be an update
--> Running transaction check
---> Package python-lxml.x86_64 0:2.3.3-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================================================================================================================================
 Package                                                            Arch                                                Version                                                        Repository                                            Size
==================================================================================================================================================================================================================================================
Updating:
 automake                                                           noarch                                              1.11.6-1.fc17                                                  updates                                              649 k
 cinnamon                                                           x86_64                                              1.6.0-1.fc17                                                   updates                                              1.2 M
 desktop-file-utils                                                 x86_64                                              0.20-4.fc17                                                    updates                                               61 k
 evolution-data-server                                              x86_64                                              3.4.4-3.fc17                                                   updates                                              2.9 M
 irqbalance                                                         x86_64                                              2:1.0.3-6.fc17                                                 updates                                               35 k
 muffin                                                             x86_64                                              1.1.0-1.fc17                                                   updates                                              1.0 M
 openconnect                                                        x86_64                                              4.07-1.fc17                                                    updates                                              233 k
 paps                                                               x86_64                                              0.6.8-20.fc17                                                  updates                                               34 k
 paps-libs                                                          x86_64                                              0.6.8-20.fc17                                                  updates                                               25 k
 ruby                                                               x86_64                                              1.9.3.194-16.fc17                                              updates                                               59 k
 ruby-irb                                                           noarch                                              1.9.3.194-16.fc17                                              updates                                               72 k
 ruby-libs                                                          x86_64                                              1.9.3.194-16.fc17                                              updates                                              2.5 M
 rubygem-bigdecimal                                                 x86_64                                              1.1.0-16.fc17                                                  updates                                               69 k
 rubygem-io-console                                                 x86_64                                              0.3-16.fc17                                                    updates                                               42 k
 rubygem-rdoc                                                       noarch                                              3.12-4.fc17                                                    updates                                              218 k
 vlgothic-fonts                                                     noarch                                              20120905-1.fc17                                                updates                                              2.2 M
 vlgothic-fonts-common                                              noarch                                              20120905-1.fc17                                                updates                                               17 k
 vlgothic-p-fonts                                                   noarch                                              20120905-1.fc17                                                updates                                              2.2 M
 webkitgtk                                                          x86_64                                              1.8.3-1.fc17                                                   updates                                              8.0 M
Installing for dependencies:
 python-lxml                                                        x86_64                                              2.3.3-1.fc17                                                   fedora                                               666 k

Transaction Summary
==================================================================================================================================================================================================================================================
Install              ( 1 Dependent package)
Upgrade  19 Packages

Total size: 22 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
ruby-irb = 1.8.7.358-1.fc15 is needed by (installed) ruby-rdoc-1.8.7.358-1.fc15.noarch
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 6 pre-existing rpmdb problem(s), 'yum check' output follows:
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.x86_64 has missing requires of libboost_serialization-mt.so.1.46.0()(64bit)
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.x86_64 has missing requires of libboost_serialization-mt.so.1.46.0()(64bit)
compiz-plugins-main-0.9.5.92-1.fc15.x86_64 has missing requires of libboost_serialization-mt.so.1.46.0()(64bit)
libcompizconfig-0.9.5.92-1.fc15.x86_64 has missing requires of libboost_serialization-mt.so.1.46.0()(64bit)
libcompizconfig-0.9.5.92-1.fc15.x86_64 has missing requires of libprotobuf.so.6()(64bit)
ruby-rdoc-1.8.7.358-1.fc15.noarch has missing requires of ruby-irb = ('0', '1.8.7.358', '1.fc15')
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-09-20.11-14.XMx6Ql.yumtx


Expected results:


Additional info:
Comment 1 Fedora End Of Life 2013-04-03 12:57:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 Valentina Mukhamedzhanova 2014-05-28 08:38:44 EDT
This is not a bug in yum. As the report states, there are pre-existing problems in the system, namely missing requires. These problems should be fixed manually, e.g. using rpm.

Note You need to log in before you can comment on or make changes to this bug.