Bug 859314 - kvm.modules and udev rules for kvm should not be installed only on x86
kvm.modules and udev rules for kvm should not be installed only on x86
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 01:23 EDT by David Gibson
Modified: 2013-01-09 07:08 EST (History)
11 users (show)

See Also:
Fixed In Version: 1.2.0.fc18-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 18:06:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
modules file updated to support ppc64 kvm (720 bytes, application/octet-stream)
2012-10-02 22:55 EDT, David Gibson
no flags Details

  None (edit)
Description David Gibson 2012-09-21 01:23:21 EDT
Description of problem:

The qemu srpm includes sample sysconfig and udev rules files to automatically load the kvm module and handle the /dev/kvm device node.  However these files are only installed in the x86-only "qemu-kvm" subpackage.  These files should also be installed on other kvm capable subpackages, such as qemu-system-ppc when built for a ppc host.
Comment 1 Daniel Berrange 2012-09-21 04:00:34 EDT
The "qemu-kvm" subpackage is not intended to be x86-only. It should pull in whichever arch-depedant system package contains the KVM binaries. It is x86-only currently because historically no other arches built KVM support.
Comment 2 David Gibson 2012-09-23 20:11:34 EDT
Ok, in that case it needs to not include the 'qemu-kvm' binary which is x86 only and hopefully to disappear in the not too distant future.

Do I need to file another bug about that package being x86 only, or can this one be repurposed.
Comment 3 David Gibson 2012-10-02 22:55:36 EDT
Created attachment 620602 [details]
modules file updated to support ppc64 kvm

In addition the current kvm.modules file is based on x86 only assumptions.  I've attached an updated version which should cover both x86 and ppc64 kvm cases.
Comment 4 Paolo Bonzini 2012-10-11 18:06:39 EDT
Thanks, I applied a similar patch to the kvm.modules script.  To support PPC builds with KVM support I had to do a relatively large restructuring of the spec file.

I removed the x86only knob and replaced it with a kvmonly knob that is closer to what the RHEL build actually wants.  http://koji.fedoraproject.org/koji/taskinfo?taskID=4583786 is a sample x86 kvmonly build, while the non-kvmonly build (http://koji.fedoraproject.org/koji/taskinfo?taskID=4583778) is the same as before.
Comment 5 Paolo Bonzini 2012-10-11 18:07:16 EDT
Ah, also all settings for KVM arches are at the top of the spec, so that adding s390 and in the future ARM support should be quite easy.

Note You need to log in before you can comment on or make changes to this bug.