Bug 859356 - Help->Contents not available
Help->Contents not available
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
20
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 05:50 EDT by Parag Nemade
Modified: 2014-03-26 05:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 05:06:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shows help not available (21.96 KB, image/png)
2012-09-21 05:50 EDT, Parag Nemade
no flags Details

  None (edit)
Description Parag Nemade 2012-09-21 05:50:23 EDT
Created attachment 615344 [details]
screen shows help not available

Description of problem:
Help contents not available.

Version-Release number of selected component (if applicable):
system-config-users-1.2.116-1.fc18.noarch

How reproducible:
always

Steps to Reproduce:
1.run system-config-users
2. try to see help->contents
3.
  
Actual results:
help content not available

Expected results:
It should be available

Additional info:
Comment 1 Parag Nemade 2012-12-26 03:59:31 EST
I am not sure if we like to show following messages as a correct way of showing contents

Document Not Found
The URI ‘ghelp:system-config-users’ does not point to a valid page.
Search for packages containing this document.

When clicked on Help button again I see

Document Not Found
The URI ‘ghelp:system-config-users?s2-system-config-users-user-new#s2-system-config-users-user-new’ does not point to a valid page.
Search for packages containing this document.


I think this bug still exists.

Tested with system-config-users-1.3.3-1.fc18.noarch
Comment 2 Parag Nemade 2013-07-16 01:14:07 EDT
Still same issue on F19
system-config-users-1.3.4-1.fc19.noarch
Comment 3 Parag Nemade 2014-02-21 01:19:49 EST
I can see this happening in f20 also.
Comment 4 Jaromír Končický 2014-03-20 08:11:14 EDT
You most probably don't have help pages installed. Try:

sudo yum install system-config-users-docs

install it and the help should work.
Yes, I admit that it's not visibly stated that you need to install docs package to get help. However, most system-config-* tools use docs package and other applications for documentation or help as well.

Please confirm that after installing it works for you, so I can close this.
Comment 5 Parag Nemade 2014-03-21 02:45:43 EDT
yes it worked after installing docs package but can't we then pull -docs for main s-c-u package?
Comment 6 Jaromír Končický 2014-03-26 05:06:27 EDT
Thanks for confirmation, closing.
Maybe the docs package is separate because it takes up some space (with its screenshots) and users who know how to use the tools don't need it. 
Nils Philippsen (nphilipp@redhat.com) is owner of the package so you can ask him more about it.

Note You need to log in before you can comment on or make changes to this bug.