Bug 859389 - Manually mounting fuse client on RHEV-H gluster-virt ISO fails
Manually mounting fuse client on RHEV-H gluster-virt ISO fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: 6.4
Assigned To: Mike Burns
Virtualization Bugs
: ZStream
Depends On:
Blocks: 863160
  Show dependency treegraph
 
Reported: 2012-09-21 08:22 EDT by Anush Shetty
Modified: 2016-04-26 09:42 EDT (History)
20 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Manually mounting a fuse client on a Red Hat Enterprise Virtualization Hypervisor gluster-virt ISO resulted in a fatal error "No such file or directory". This issue is caused by the blacklisting of the fuse kernel modules in the build system. This fix keeps the fuse kernel modules, allowing the system to recognize the file when it is mounted.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:39:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-09-21 08:22:25 EDT
Description of problem: Manually mounting fuse client on RHEV-H gluster-virt ISO fails. 


Version-Release number of selected component (if applicable):

ISO - rhev-hypervisor6-6.3-20120920.0.rhev31.auto30.el6.iso

# rpm -qa | grep glus
glusterfs-rdma-3.3.0.2rhs-30.el6.x86_64
glusterfs-3.3.0.2rhs-30.el6.x86_64
glusterfs-fuse-3.3.0.2rhs-30.el6.x86_64
glusterfs-devel-3.3.0.2rhs-30.el6.x86_64


How reproducible: Consistently


Steps to Reproduce:
1. Create a gluster volume 
2. Mount the fuse client from RHEV-H machine - mount -t glusterfs rhs-gp-srv11.lab.eng.blr.redhat.com:/distrep2 /opt/
3.
  
Actual results:

Mount failed. Please check the log file for more details.


Expected results:

Mount should succeed 

Additional info:

Log:

[2012-09-21 05:07:34.435107] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.0.2rhs
[2012-09-21 05:07:34.463622] E [mount.c:596:gf_fuse_mount] 0-glusterfs-fuse: cannot open /dev/fuse (No such device)
[2012-09-21 05:07:34.463711] E [xlator.c:385:xlator_init] 0-fuse: Initialization of volume 'fuse' failed, review your volfile again
[2012-09-21 05:09:52.357729] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.0.2rhs
[2012-09-21 05:09:52.371413] E [mount.c:596:gf_fuse_mount] 0-glusterfs-fuse: cannot open /dev/fuse (No such device)
[2012-09-21 05:09:52.371447] E [xlator.c:385:xlator_init] 0-fuse: Initialization of volume 'fuse' failed, review your volfile again
[2012-09-21 05:10:12.367059] I [glusterfsd.c:1666:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.0.2rhs
[2012-09-21 05:10:12.377962] E [mount.c:596:gf_fuse_mount] 0-glusterfs-fuse: cannot open /dev/fuse (No such device)
[2012-09-21 05:10:12.378022] E [xlator.c:385:xlator_init] 0-fuse: Initialization of volume 'fuse' failed, review your volfile again
 
# modprobe fuse
FATAL: Could not open '/lib/modules/2.6.32-279.9.1.el6.x86_64/kernel/fs/fuse/fuse.ko': No such file or directory
Comment 2 Mike Burns 2012-09-21 10:05:56 EDT
moving to ovirt-node, this is caused by our blacklisting
Comment 4 Mike Burns 2012-09-21 10:22:03 EDT
upstream patch

http://gerrit.ovirt.org/#/c/8117/
Comment 5 Anush Shetty 2012-09-25 05:28:12 EDT
Works now with rhev-hypervisor6-6.3-20120920.0.rhev31.auto33.el6.iso.
Comment 8 Mike Burns 2012-10-11 07:58:09 EDT
Ouyang,  

The glusterfs client rpms are only being included in special jenkins builds at the moment.  It's really still in POC stage, though I'm working now on getting this into official builds
Comment 13 errata-xmlrpc 2013-02-28 11:39:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.