Bug 859398 - 3.0.z - audit_log table is not cleaned properly, causing rhevm database to grow excessively
3.0.z - audit_log table is not cleaned properly, causing rhevm database to gr...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.0.7
All Linux
urgent Severity high
: ---
: 3.0.8
Assigned To: Eli Mesika
Pavel Stehlik
infra
: Regression, ZStream
Depends On: 856009
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 08:57 EDT by Chris Pelland
Modified: 2016-02-10 14:10 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the DeleteAuditLogOlderThanDate command only removed audit logs when the "processed=TRUE" condition was set, causing the database to grow excessively. With this update, "processed=TRUE" is no longer a condition to remove logs. DeleteAuditLogOlderThanDate now removes logs on the periodic time it is configured to do so, which is 30 days by default.
Story Points: ---
Clone Of: 856009
Environment:
Last Closed: 2012-11-27 07:23:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 209253 None None None 2012-09-21 08:57:43 EDT

  None (edit)
Comment 2 Eli Mesika 2012-10-09 06:15:08 EDT
fixed in commit : fb24ffb
Comment 6 errata-xmlrpc 2012-11-27 07:23:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1496.html

Note You need to log in before you can comment on or make changes to this bug.