Bug 859440 - glibc build failure in rawhide
glibc build failure in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 10:40 EDT by Siddhesh Poyarekar
Modified: 2016-11-24 07:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 17:10:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Siddhesh Poyarekar 2012-09-21 10:40:02 EDT
Looks like glibc-2.16.90-13.fc19 is also causing build failures, this time in glibc itself:

http://kojipkgs.fedoraproject.org//work/tasks/1483/4511483/build.log

---------------------------------------------------------------------
mkdir /builddir/build/BUILDROOT/glibc-2.16.90-13.fc19.0.test.x86_64/usr/share/locale/vi/LC_MESSAGES
make[2]: Leaving directory `/builddir/build/BUILD/glibc-2.16.90-97bc38d7/po'
make[2]: *** [da.mo] Segmentation fault
make[1]: *** [po/subdir_install] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/glibc-2.16.90-97bc38d7'
make: Leaving directory `/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-x86_64-redhat-linux'
make: *** [install] Error 2
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.g9A9m7 (%install)
    Bad exit status from /var/tmp/rpm-tmp.g9A9m7 (%install)
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/glibc.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/mockbuild/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.6/site-packages/mockbuild/util.py", line 352, in do
    raise mockbuild.exception.Error, ("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
Error: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/glibc.spec']
LEAVE do --> EXCEPTION RAISED
---------------------------------------------------------------------


So it looks like there's more in -12.fc19 that may be causing breakages.
Comment 1 Jakub Jelinek 2012-09-21 10:41:53 EDT
gcc build in rawhide also failed with:
make[3]: *** [po/ca.gmo] Segmentation fault
make[3]: *** Waiting for unfinished jobs....
(worked a day ago and seems to work for f18/f17).
Comment 2 Siddhesh Poyarekar 2012-09-21 11:06:48 EDT
This is probably because of glibc-rh816647.patch.  There are a bunch of iconv test case failures due to segfaults in -12.fc19 as well as -13.fc19 build logs that I failed to notice earlier:

bug-iconv9.c:41:8: warning: format '%jd' expects argument of type 'intmax_t', but argument 2 has type 'int' [-Wformat]
/bin/sh: line 1:  2798 Segmentation fault      GCONV_PATH=/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata LC_ALL=C /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf/ld-linux.so.2 --library-path /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/math:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/dlfcn:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nss:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nis:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/rt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/resolv:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/crypt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nptl /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv2 > /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv2.out
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv2.out] Error 139
/bin/sh: line 1:  2802 Segmentation fault      GCONV_PATH=/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata LC_ALL=C /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf/ld-linux.so.2 --library-path /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/math:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/dlfcn:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nss:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nis:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/rt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/resolv:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/crypt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nptl /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-e2big > /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-e2big.out
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-e2big.out] Error 139
/bin/sh: line 1:  2799 Segmentation fault      GCONV_PATH=/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata LC_ALL=C /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf/ld-linux.so.2 --library-path /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/math:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/dlfcn:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nss:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nis:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/rt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/resolv:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/crypt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nptl /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv1 > /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv1.out
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv1.out] Error 139
Didn't expect signal from child: got `Segmentation fault'
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-iconv4.out] Error 1
/bin/sh: line 1:  2808 Segmentation fault      GCONV_PATH=/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata LC_ALL=C /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf/ld-linux.so.2 --library-path /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/math:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/dlfcn:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nss:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nis:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/rt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/resolv:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/crypt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nptl /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv4 > /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv4.out
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv4.out] Error 139
Didn't expect signal from child: got `Segmentation fault'
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-iconv6.out] Error 1
Didn't expect signal from child: got `Segmentation fault'
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/bug-iconv8.out] Error 1
Testing ASCII
Testing ISO646-GB/bin/sh: line 1:  2803 Segmentation fault      GCONV_PATH=/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata LC_ALL=C MALLOC_TRACE=/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-loading.mtrace /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf/ld-linux.so.2 --library-path /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/math:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/elf:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/dlfcn:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nss:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nis:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/rt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/resolv:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/crypt:/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/nptl /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-loading > /builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-loading.out
make[2]: *** [/builddir/build/BUILD/glibc-2.16.90-97bc38d7/build-i686-redhat-linux/iconvdata/tst-loading.out] Error 139

http://kojipkgs.fedoraproject.org//packages/glibc/2.16.90/12.fc19/data/logs/i686/build.log
http://kojipkgs.fedoraproject.org//packages/glibc/2.16.90/13.fc19/data/logs/i686/build.log
Comment 3 Vít Ondruch 2012-09-21 11:24:52 EDT
I also observer crashes in test suite of Rubinius package I am working on. It happens since .12 release. Here is the backtrace I have and I can provide coredump as well, if it helps.:

Rubinius Crash Report #rbxcrashreport

Error: signal 

[[Backtrace]]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci[0x5980ae]
/lib64/libpthread.so.0(+0xf550)[0x7ff3752b8550]
/lib64/libc.so.6(+0x23150)[0x7ff3747e7150]
/lib64/libc.so.6(+0x240e4)[0x7ff3747e80e4]
/lib64/libc.so.6(iconv_close+0xf)[0x7ff3747e658f]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(ffi_call_unix64+0x4c)[0x7b00e8]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(ffi_call+0x406)[0x7afad9]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius14NativeFunction4callEPNS_5StateERNS_9ArgumentsEPNS_9CallFrameE+0xf7d)[0x69fe0d]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius14NativeFunction7executeEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0x82)[0x6a0562]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode11interpreterEPNS_5StateEPS0_PNS_20InterpreterCallFrameE+0x2d73)[0x5ba193]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode19execute_specializedINS_11NoArgumentsEEEPNS_6ObjectEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0x1ba)[0x5f1aea]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode11interpreterEPNS_5StateEPS0_PNS_20InterpreterCallFrameE+0x2d73)[0x5ba193]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode19execute_specializedINS_12TwoArgumentsEEEPNS_6ObjectEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0x24f)[0x5f113f]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode11interpreterEPNS_5StateEPS0_PNS_20InterpreterCallFrameE+0x2e96)[0x5ba2b6]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode19execute_specializedINS_16GenericArgumentsEEEPNS_6ObjectEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0x21a)[0x5f039a]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode11interpreterEPNS_5StateEPS0_PNS_20InterpreterCallFrameE+0x2d73)[0x5ba193]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode19execute_specializedINS_14ThreeArgumentsEEEPNS_6ObjectEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0x257)[0x5f0dc7]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11InlineCache11empty_cacheEPNS_5StateEPS0_PNS_9CallFrameERNS_9ArgumentsE+0x11c)[0x5a540c]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode11interpreterEPNS_5StateEPS0_PNS_20InterpreterCallFrameE+0x2d73)[0x5ba193]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius16BlockEnvironment19execute_interpreterEPNS_5StateEPNS_9CallFrameEPS0_RNS_9ArgumentsERNS_15BlockInvocationE+0x202)[0x676132]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius16BlockEnvironment6invokeEPNS_5StateEPNS_9CallFrameEPS0_RNS_9ArgumentsERNS_15BlockInvocationE+0x7d)[0x67678d]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius16BlockEnvironment10call_underEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0xab)[0x676a9b]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius10Primitives16block_call_underEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0xce)[0x62fd8e]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode11interpreterEPNS_5StateEPS0_PNS_20InterpreterCallFrameE+0x2d73)[0x5ba193]
/builddir/build/BUILD/rubinius-rubinius-aac4fb6/mspec/bin/mspec-ci(_ZN8rubinius11MachineCode19execute_specializedINS_16GenericArgumentsEEEPNS_6ObjectEPNS_5StateEPNS_9CallFrameEPNS_10ExecutableEPNS_6ModuleERNS_9ArgumentsE+0x21a)[0x5f039a]
[0x7ff37007e112]

[[System Info]]
sysname: Linux
nodename: dhcp-25-1.brq.redhat.com
release: 3.5.3-1.fc17.x86_64
version: #1 SMP Wed Aug 29 18:46:34 UTC 2012
machine: x86_64
Comment 4 Jeff Law 2012-09-21 12:13:22 EDT
I'm working on it.  Thanks,
Comment 5 Jeff Law 2012-09-21 17:10:12 EDT
Offending patch backed out, builds respun.

Note You need to log in before you can comment on or make changes to this bug.