Bug 859461 - In ADD A KEYBOARD LAYOUT typing brings up additional find window
In ADD A KEYBOARD LAYOUT typing brings up additional find window
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 11:43 EDT by Stef Walter
Modified: 2012-09-24 08:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 07:31:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2012-09-21 11:43:01 EDT
Description of problem:

When in the ADD A KEYBOARD LAYOUT dialog, with the focus on the big list, typing doesn't filter the list. Instead it brings up an additional little entry window to type into.

There's a filter entry below the big list. It's confusing to have two search/filter interfaces driven by typing for the same list. Typing should just focus the filter entry below the list, and result in the list being filtered.

Version-Release number of selected component (if applicable):

FEDORA 18-Alpha INSTALLATION

How reproducible:

Every time.
Comment 1 Vratislav Podzimek 2012-09-24 07:31:35 EDT
(In reply to comment #0)
> Description of problem:
> 
> When in the ADD A KEYBOARD LAYOUT dialog, with the focus on the big list,
> typing doesn't filter the list. Instead it brings up an additional little
> entry window to type into.
> 
> There's a filter entry below the big list. It's confusing to have two
> search/filter interfaces driven by typing for the same list. Typing should
> just focus the filter entry below the list, and result in the list being
> filtered.
That would be confusing, because typing in the list usually results in searching in the list. As we are trying to avoid non-standard behaviour in the GUI, I'm closing this bug as NOTABUG.
Comment 2 Stef Walter 2012-09-24 08:20:26 EDT
BTW, see https://bugzilla.gnome.org/show_bug.cgi?id=684565 for why *both* filtering and/or searching based interfaces are broken for this use case.

Note You need to log in before you can comment on or make changes to this bug.