Bug 859486 - mana has file conflicts with manaworld
mana has file conflicts with manaworld
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mana (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Erik Schilling
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 12:19 EDT by Bruno Wolff III
Modified: 2012-10-18 03:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 03:42:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-09-21 12:19:57 EDT
Description of problem:
file /usr/bin/mana from install of mana-0.6.1-5.fc18.x86_64 conflicts with file from package manaworld-0.5.2-9.fc18.x86_64 amoung others.
Is there an obsoletes missing as it looks like mana is supposed to replace manaworld? (If that is the case, comps should get changed to reflect that as well.)
Comment 1 Erik Schilling 2012-09-21 12:52:45 EDT
Ahw. I thought the manaworld package would have renamed the binaries.
Mana itself does not obsolute manaworld

Mana is a generic client. It is used by multiple games. However games can provide brandings for mana. But they should do this without providing own binaries.

There *should* be a package that only provides the branding and depends on mana.

So manaworld should be replaced by a package that provides the tmw branding (https://github.com/themanaworld/tmw-branding).

So what should be done? Obsoluting manaworld seems wrong to me since The Mana World has a different client theme.

I guess best would be to fix the manaworld package to do proper theming (not copy source + brand it directly). But i do not even know if manaworld is still the right/preferred name... Debian uses tmw simply for eg...

Regards and thanks for pointing out
Erik
Comment 2 Erik Schilling 2012-09-22 09:11:08 EDT
I mailed the maintainer of manaworld and asked him to modify the package to only include the branding data and no binaries.

Regards
Erik
Comment 3 Erik Schilling 2012-10-18 03:42:03 EDT
The tmw package was fixed: https://bugzilla.redhat.com/show_bug.cgi?id=860697

Note You need to log in before you can comment on or make changes to this bug.