Bug 859503 - If launch is selected when an application named the same as blueprint already exists an error is thrown
If launch is selected when an application named the same as blueprint already...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta3
: ---
Assigned To: Imre Farkas
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 13:12 EDT by james labocki
Modified: 2016-09-20 01:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If an application was launched from a previously used blueprint, an error occured stating: "Name has already been taken" This fixed set the name and checks for duplicates only after clicking the "Next" button. The system now redirects to a form where the name of the deployment can be set.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:20:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen1 (53.22 KB, image/png)
2012-09-21 13:13 EDT, james labocki
no flags Details
screen2 (68.55 KB, image/png)
2012-09-21 13:13 EDT, james labocki
no flags Details
duplicate check (85.47 KB, image/png)
2012-09-28 08:00 EDT, pushpesh sharma
no flags Details
application Blueprint name error (88.18 KB, image/png)
2012-09-28 08:04 EDT, pushpesh sharma
no flags Details

  None (edit)
Description james labocki 2012-09-21 13:12:41 EDT
Description of problem:

If a user launches an application from a blueprint using the blueprint's name and then returns to the catalog and selects "launch" again on the same application blueprint an error will appear stating  "Name has already been taken" . This seems like a logic problem, because the user did not set the name, but it is already filled in. It would appear that we could:

1. Not set the application name and only check for a duplicate name when "next" is selected.
2. Generate a Unique Identifier (still user friendly like the way Amazon names each AMI)

Either way, we should not alarm that the name is already taken when the blueprint is only selected.

See screenshots for more.
Comment 1 james labocki 2012-09-21 13:13:06 EDT
Created attachment 615527 [details]
screen1
Comment 2 james labocki 2012-09-21 13:13:37 EDT
Created attachment 615528 [details]
screen2
Comment 4 Imre Farkas 2012-09-24 07:45:36 EDT
For me the first approach is user-friendlier, so fixed in that way. The pull request sent:
https://github.com/aeolusproject/conductor/pull/74
Comment 5 Tzu-Mainn Chen 2012-09-24 11:03:37 EDT
ACK'd and pushed to master/1.1:

commit 689c15931538a9d794191a645b89105b41922e89
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Mon Sep 24 13:39:54 2012 +0200

    BZ #859503: laucn new deployment button on deployables#show redirects to deployments#launch_new instead of deploy
    (cherry picked from commit 081f3d2e188a6b4e3b53d9e313a6ab8c0f9cee73)
Comment 7 Imre Farkas 2012-09-24 12:05:11 EDT
Just for clarification, the user is now redirected to the form where the name of the deployment can be set. So the error message without any user interaction is gone but the name remains the same even if there's an existing one.
Comment 8 pushpesh sharma 2012-09-28 08:00:01 EDT
1.Try to launch a application with Blueprint name--->Success
2.Tried again the above and got the message "Name already taken" before pressing the next button. 

"Not set the application name and only check for a duplicate name when "next" is selected." recommendation is applied. 

Verified on :

[root@dhcp201-113 ~]# rpm -qa |grep aeolus
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
[root@dhcp201-113 ~]#
Comment 9 pushpesh sharma 2012-09-28 08:00:51 EDT
Created attachment 618534 [details]
duplicate check
Comment 10 pushpesh sharma 2012-09-28 08:04:38 EDT
Created attachment 618535 [details]
application Blueprint name error
Comment 12 errata-xmlrpc 2012-12-04 10:20:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.