Bug 859585 - ibus-setup SEGV by async IBus.Bus
ibus-setup SEGV by async IBus.Bus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:8d5a7a3e5700c335affa467ae07...
:
: 868279 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 02:44 EDT by NeoRaidenX
Modified: 2012-12-20 11:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:09:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (264 bytes, text/plain)
2012-09-22 02:44 EDT, NeoRaidenX
no flags Details
Patch for setup/main.py (1.23 KB, patch)
2012-09-25 22:21 EDT, fujiwara
no flags Details | Diff

  None (edit)
Description NeoRaidenX 2012-09-22 02:44:07 EDT
Version-Release number of selected component:
ibus-1.4.99.20120822-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py
kernel:         3.3.4-5.fc17.x86_64

backtrace:
:main.py:269:__init_ui:AttributeError: 'NoneType' object has no attribute 'connect'
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/main.py", line 665, in <module>
:    setup = Setup()
:  File "/usr/share/ibus/setup/main.py", line 75, in __init__
:    self.__init_ui()
:  File "/usr/share/ibus/setup/main.py", line 269, in __init_ui
:    self.__config.connect("value-changed", self.__config_value_changed_cb)
:AttributeError: 'NoneType' object has no attribute 'connect'
:
:Local variables in innermost frame:
:self: <__main__.Setup object at 0x1a1ab90>
Comment 1 NeoRaidenX 2012-09-22 02:44:10 EDT
Created attachment 615695 [details]
File: core_backtrace
Comment 2 fujiwara 2012-09-25 22:18:52 EDT
I cannot reproduce this problem. But probably I think this bug and bug #848023 has the same root cause.
Comment 3 fujiwara 2012-09-25 22:21:05 EDT
Created attachment 617351 [details]
Patch for setup/main.py

Here is the tentative patch.
I'd prefer to use the async function likes bug #848023 but it might be complicated since ibus-setup runs ibus-daemon.
Comment 4 Fedora Update System 2012-10-06 10:11:14 EDT
ibus-1.4.99.20121006-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20121006-1.fc18
Comment 5 Fedora Update System 2012-10-06 10:11:32 EDT
ibus-1.4.99.20121006-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20121006-1.fc17
Comment 6 Fedora Update System 2012-10-06 14:42:45 EDT
Package ibus-1.4.99.20121006-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.99.20121006-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15547/ibus-1.4.99.20121006-1.fc18
then log in and leave karma (feedback).
Comment 7 fujiwara 2012-10-21 22:23:36 EDT
*** Bug 868279 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-12-20 11:09:28 EST
ibus-1.4.99.20121006-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.