This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 8596 - linuxconf can not assign Alternate Local Networks
linuxconf can not assign Alternate Local Networks
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-19 04:20 EST by Harry Brueckner
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Brueckner 2000-01-19 04:20:46 EST
Hello,

I am running RH 6.1 and have a problem regarding linuxconf and the menu
"Config/Networking/Client tasks/Routing and gateways/Set routes to
alternate local nets".

When I enter the network data from the second network which is routed to my
eth0 interface the file /etc/sysconfig/static-routes shows a line like
this:

any net <my network number> netmask <my netmask> gw eth0

and the script /etc/rc.d/init.d/network tries to process this line to setup
the route like this:

/sbin/route add -net <my network number> netmask <my netmask> gw eth0

The problem with that is, that its not a legal call to the route (v1.96)
command since I do not want to route to a certain host but to the device
eth0.
The command which should be created (and which works when I run it
manually) is:

/sbin/route add -net <my network number> netmask <my netmask> dev eth0

The "gw" argument must be replaced with "dev" in this case because the
program asks for a device and not a hostname.

Am I wrong to use this menu for my needs or is this a bug?

Thanks for any help.

Harry
Comment 1 Brent Fox 2002-06-05 12:12:58 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Red Hat Bugzilla 2006-02-21 13:47:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.