This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 859616 - [abrt] evolution-3.4.4-1.fc17: __libc_recv: Process /usr/libexec/evolution/3.4/evolution-alarm-notify was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.4-1.fc17: __libc_recv: Process /usr/libexec/evolution/3....
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:9202a452db3919311b5578730df...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 09:16 EDT by Andrew Vagin
Modified: 2012-10-16 04:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: evolution-3.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 04:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (3.43 KB, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: environ (1.45 KB, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: backtrace (26.26 KB, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: cgroup (129 bytes, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: maps (60.88 KB, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: dso_list (12.39 KB, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: var_log_messages (728 bytes, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details
File: open_fds (575 bytes, text/plain)
2012-09-22 09:16 EDT, Andrew Vagin
no flags Details

  None (edit)
Description Andrew Vagin 2012-09-22 09:16:07 EDT
Description of problem:
evolution-alarm-notify ate 100% cpu, I killed its for creating this report.
Here is a strace log:
[pid  1502] poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
[pid  1502] recvfrom(3, 0x25792f4, 4096, 0, 0, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid  1502] poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
[pid  1502] recvfrom(3, 0x25792f4, 4096, 0, 0, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid  1502] poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
[pid  1502] recvfrom(3, 0x25792f4, 4096, 0, 0, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid  1502] poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)

I see this bug very often. Probably it's reproduced after suspend/resume.


Version-Release number of selected component:
evolution-3.4.4-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/libexec/evolution/3.4/evolution-alarm-notify
crash_function: __libc_recv
kernel:         3.5.3-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 __libc_recv at ../sysdeps/unix/sysv/linux/x86_64/recv.c
: #1 recv at /usr/include/bits/socket2.h
: #2 _xcb_in_read at xcb_in.c
: #3 poll_for_next_event at xcb_in.c
: #4 xcb_poll_for_event at xcb_in.c
: #5 poll_for_event at xcb_io.c
: #6 poll_for_response at xcb_io.c
: #7 _XEventsQueued at xcb_io.c
: #8 XPending at Pending.c
: #9 gdk_check_xpending at gdkeventsource.c
Comment 1 Andrew Vagin 2012-09-22 09:16:10 EDT
Created attachment 615788 [details]
File: core_backtrace
Comment 2 Andrew Vagin 2012-09-22 09:16:12 EDT
Created attachment 615789 [details]
File: environ
Comment 3 Andrew Vagin 2012-09-22 09:16:14 EDT
Created attachment 615790 [details]
File: limits
Comment 4 Andrew Vagin 2012-09-22 09:16:16 EDT
Created attachment 615791 [details]
File: backtrace
Comment 5 Andrew Vagin 2012-09-22 09:16:18 EDT
Created attachment 615792 [details]
File: cgroup
Comment 6 Andrew Vagin 2012-09-22 09:16:20 EDT
Created attachment 615793 [details]
File: maps
Comment 7 Andrew Vagin 2012-09-22 09:16:22 EDT
Created attachment 615794 [details]
File: dso_list
Comment 8 Andrew Vagin 2012-09-22 09:16:24 EDT
Created attachment 615795 [details]
File: var_log_messages
Comment 9 Andrew Vagin 2012-09-22 09:16:26 EDT
Created attachment 615796 [details]
File: open_fds
Comment 10 Milan Crha 2012-10-16 04:56:20 EDT
Thanks for a bug report. I see it's caused by a password prompt, it has some trouble showing the password prompt dialog. The evolution 3.6.x has done password prompts differently, with many other things around password asking being improved, thus I'm closing this in favour of the 3.6.x.

Note You need to log in before you can comment on or make changes to this bug.