Bug 859635 - Magnet links in RSS feeds don't download automatically
Magnet links in RSS feeds don't download automatically
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qbittorrent (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 12:56 EDT by Patrick O'Callaghan
Modified: 2012-09-23 10:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-22 13:13:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick O'Callaghan 2012-09-22 12:56:10 EDT
Description of problem:
Old-style torrent file links in RSS feeds download automatically when the feed is updated. Magnet links don't.

Version-Release number of selected component (if applicable):
3.0.4 (and earlier)

How reproducible:
Always

Steps to Reproduce:
1.Enter feeds in the RSS tab which produce magnet links instead of torrent files
2.Observe that feeds update correctly both manually and automatically
3.Observe that updated feeds fail to download unless the user right-clicks and does so manually
  
Actual results:
No automatic downloads for magnet links

Expected results:
Magnet links should work in the same way as the old torrent file links do

Additional info:
In fact meta-info: I was unable to report this at the qbittorrent Launchpad page, which now states that it is not a tracker for QBT bugs and sends me to a GitHub page. The GitHub page appears to have no means of registering a new user and says that QBT bugs are tracked on Launchpad.
Comment 1 leigh scott 2012-09-22 13:13:12 EDT
Please report it upstream.
Comment 2 Patrick O'Callaghan 2012-09-22 16:09:40 EDT
As I already stated, this doesn't appear to be possible at present.
Comment 3 leigh scott 2012-09-22 16:38:23 EDT
(In reply to comment #2)
> As I already stated, this doesn't appear to be possible at present.

https://github.com/qbittorrent/qBittorrent/issues/116
Comment 4 Patrick O'Callaghan 2012-09-22 19:31:18 EDT
Thanks.
Comment 5 Christophe Dumez 2012-09-23 03:20:09 EDT
(In reply to comment #0)
> Additional info:
> In fact meta-info: I was unable to report this at the qbittorrent Launchpad
> page, which now states that it is not a tracker for QBT bugs and sends me to
> a GitHub page. The GitHub page appears to have no means of registering a new
> user and says that QBT bugs are tracked on Launchpad.

The new bug tracker is on Github and works just fine (http://bugs.qbittorrent.org). I get a lot of bug reports so I'm sure it works. Anyone can register an account on Github...
https://github.com/signup/free

Please tell me where it says that qBT bugs are tracked on Launchpad because I cannot find any mention of this.
Comment 6 Christophe Dumez 2012-09-23 03:23:52 EDT
Automated download of magnet links from RSS feeds has been supported for quite some time. I have just tested to make sure it is not broken. It is working just fine for me. It may be an issue specific to the RSS stream you're testing but it is difficult for me to tell without having the link.

I found one bug - however - When adding a new download rule, it currently applies to new rss articles only, and not to the existing ones. I'm fixing it right now but this is not specific to magnet link feeds.
Comment 7 Christophe Dumez 2012-09-23 03:41:25 EDT
(In reply to comment #6)
> Automated download of magnet links from RSS feeds has been supported for
> quite some time. I have just tested to make sure it is not broken. It is
> working just fine for me. It may be an issue specific to the RSS stream
> you're testing but it is difficult for me to tell without having the link.
> 
> I found one bug - however - When adding a new download rule, it currently
> applies to new rss articles only, and not to the existing ones. I'm fixing
> it right now but this is not specific to magnet link feeds.

The bug I found only affected v3.1.0alpha. With v3.0.4, I cannot reproduce the any of these issues.
Comment 8 Patrick O'Callaghan 2012-09-23 09:18:05 EDT
Thanks Cristophe, I've now signed up to GitHub. I was confused because neither bugs.qbittorrent.com nor the GitHub login page links to the signup page and I didn't look any further.

Also, I can no longer find the mention of LaunchPad so let's forget that.
Comment 9 Patrick O'Callaghan 2012-09-23 09:19:53 EDT
(In reply to comment #6)
> Automated download of magnet links from RSS feeds has been supported for
> quite some time. I have just tested to make sure it is not broken. It is
> working just fine for me. It may be an issue specific to the RSS stream
> you're testing but it is difficult for me to tell without having the link.
> 
> I found one bug - however - When adding a new download rule, it currently
> applies to new rss articles only, and not to the existing ones. I'm fixing
> it right now but this is not specific to magnet link feeds.

The specific feed I'm having problems with is http://showrss.karmorra.info/

poc
Comment 10 Christophe Dumez 2012-09-23 09:22:48 EDT
(In reply to comment #9)
> (In reply to comment #6)
> > Automated download of magnet links from RSS feeds has been supported for
> > quite some time. I have just tested to make sure it is not broken. It is
> > working just fine for me. It may be an issue specific to the RSS stream
> > you're testing but it is difficult for me to tell without having the link.
> > 
> > I found one bug - however - When adding a new download rule, it currently
> > applies to new rss articles only, and not to the existing ones. I'm fixing
> > it right now but this is not specific to magnet link feeds.
> 
> The specific feed I'm having problems with is http://showrss.karmorra.info/
> 
> poc

Well, that is interesting because http://showrss.karmorra.info/ is actually the one I used for testing as well.
Comment 11 Patrick O'Callaghan 2012-09-23 09:26:30 EDT
I'm happy to doing any testing of this, but the problem is completely solid, i.e. no magnet torrents are ever downloaded automatically. I always have to right-click.

Is there some configuration option I'm forgetting? I can send you my config file if that will help (just tell me which one it is).
Comment 12 Christophe Dumez 2012-09-23 09:55:39 EDT
Patrick, I doubt this is a configuration issue. Can you please send me your RSS link via email (chris at qBittorrent dot org) ? Maybe it is slightly different than the one I tested...

Here is what I tried (with qBittorrent v3.0.4):
1. I generated a showrss feed and copied the one indicated as: "Full feed with magnets:"
2. I added this feed to qBittorrent
3. I went to the automated RSS downloaded, created a rule with the name of a TV show and applied the rule to the Karmorra RSS feed (it matched 3 articles)
4. I closed the automated RSS downloader dialog and qBittorrent automatically added those 3 magnet links to the transfer list.

I'm running this on Mac OS X but it shouldn't matter. The code here is pretty simple: If the link starts with "magnet:" (case insensitive), it is added as a magnet, otherwise it is considered to be a URL to a torrent file.

Note that automated RSS rules do not apply to RSS articles that have already been marked as read.
Comment 13 Patrick O'Callaghan 2012-09-23 10:43:21 EDT
Perhaps the problem is that I'm doing the selection at the showrss end, i.e. I have a single URL which selects all my desired feeds using the on-site selection mechanism, and that single feed is what I register in the RSS tab. QBT does indicate new shows when they appear, so I assumed that was the correct way to do it.

We can continue this offline. I mailed you my rssinfo details.

Note You need to log in before you can comment on or make changes to this bug.