Bug 859652 - subscribe with service-level is being ignored (certv3 only)
subscribe with service-level is being ignored (certv3 only)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-rhsm (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity urgent
: ---
: 5.9
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-22 15:32 EDT by John Sefler
Modified: 2013-01-08 02:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:18:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-09-22 15:32:22 EDT
Description of problem:
When specifying a service-level with autosubscribe, the entitlements granted do not come from an order with the requested service level.  They should.  This is a regression.


Version-Release number of selected component (if applicable):
[root@jsefler-f14-candlepin candlepin]# git show-ref | grep master
d29c9b4a4f61f2db96f91b79630ee2f4c6568899 refs/heads/master
d29c9b4a4f61f2db96f91b79630ee2f4c6568899 refs/remotes/origin/master

[root@jsefler-rhel59 ~]# subscription-manager version
registered to: 0.7.11-1
server type: subscription management service
subscription-manager: 1.1.1-1.git.27.c6ddb3c.el5
python-rhsm: 1.1.1-1.git.0.3e9bbcf.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel59 ~]# subscription-manager register --username testuser1 --password password --org admin
The system has been registered with id: f4729acf-7a81-48e2-8617-e80153c094fe 
[root@jsefler-rhel59 ~]# subscription-manager service-level --list
+-------------------------------------------+
               Available Service Levels
+-------------------------------------------+
None
Premium
Standard
ultimate sla

[root@jsefler-rhel59 ~]# subscription-manager list --consumed
No consumed subscription pools to list

[root@jsefler-rhel59 ~]# subscription-manager subscribe --auto --servicelevel=Premium
Service level set to: Premium
Installed Product Current Status:
Product Name:         	Awesome OS for ia64 Bits
Status:               	Not Subscribed

Product Name:         	Stackable with Awesome OS for x86_64 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS Developer Basic
Status:               	Not Subscribed

Product Name:         	Awesome OS for x86_64/i686/ia64/ppc/ppc64/s390x/s390 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for z80/x86_64 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for z80/ALL Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for x86_64/ALL Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for x86_64/ALL Bits for ZERO sockets
Status:               	Not Subscribed

Product Name:         	Exempt Product Bits
Status:               	Subscribed

Product Name:         	Awesome OS Workstation Bits
Status:               	Not Subscribed

Product Name:         	Red Hat Enterprise Linux Server
Status:               	Not Subscribed

Product Name:         	Awesome OS Scalable Filesystem Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS Developer Bits
Status:               	Not Subscribed

Product Name:         	Management Bits
Status:               	Subscribed

Product Name:         	Large File Support Bits
Status:               	Subscribed

Product Name:         	Awesome OS Modifier Bits
Status:               	Not Subscribed

Product Name:         	Clustering Bits
Status:               	Subscribed

Product Name:         	Shared Storage Bits
Status:               	Subscribed

Product Name:         	Awesome OS Server Bits
Status:               	Subscribed

Product Name:         	Awesome OS Premium Architecture Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for S390 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for i686/x86_64 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for z80 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for i686 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for x86_64 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for ppc64 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for S390X Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for i386 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for x86 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for x86/x64_64 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for Intel x86_64/i686/ia64 Bits
Status:               	Not Subscribed

Product Name:         	Awesome OS for x86_64/s390x Bits
Status:               	Not Subscribed

Product Name:         	Shared File System Bits
Status:               	Subscribed

Product Name:         	Multiplier Product Bits
Status:               	Not Subscribed

Product Name:         	Load Balancing Bits
Status:               	Subscribed

[root@jsefler-rhel59 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Awesome OS Server Bundled
Provides:             	Clustering Bits
                      	Awesome OS Server Bits
                      	Load Balancing Bits
                      	Large File Support Bits
                      	Shared Storage Bits
                      	Management Bits
SKU:                  	awesomeos-server
Contract:             	7
Account:              	12331131231
Serial Number:        	8496863372596470195
Active:               	True
Quantity Used:        	1
Service Level:        	Level 3        <=================== EXPECTED Premium
Service Type:         	
Starts:               	09/21/2012
Ends:                 	09/21/2013

Subscription Name:    	An "Exempt SLA" service level subscription (matches all service levels)
Provides:             	Exempt Product Bits
SKU:                  	exempt-sla-product-sku
Contract:             	1082339129
Account:              	43807317
Serial Number:        	6715869800175576393
Active:               	True
Quantity Used:        	1
Service Level:        	
Service Type:         	
Starts:               	09/21/2012
Ends:                 	10/07/2012

Subscription Name:    	Shared File System
Provides:             	Shared File System Bits
SKU:                  	sfs
Contract:             	126
Account:              	12331131231
Serial Number:        	4436016758694185167
Active:               	True
Quantity Used:        	1
Service Level:        	          <=================== EXPECTED Premium
Service Type:         	
Starts:               	09/21/2012
Ends:                 	09/21/2013

  
Actual results:
above

Expected results:
Every entitlment granted (excluding the exempt service level subscription) should have had a service level of "Premium" since that was asked for in the autosubscribe.

Additional info:
Comment 1 John Sefler 2012-09-24 10:56:52 EDT
This appears to be related to certv1 versus certv3.
With fact system.certificate_version: 3.0, I get the wrong results.
With fact system.certificate_version: 1.0, I get the right results.
Comment 2 William Poteat 2012-09-25 12:52:00 EDT
python-rhsm master commit 4925dc9751a2917461cf171ce7b08aeb89691181
Comment 4 RHEL Product and Program Management 2012-09-25 14:07:31 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 spandey 2012-09-26 07:22:32 EDT
Verified using following rpm .

subscription-manager-firstboot-1.0.20-1.el5
subscription-manager-1.0.20-1.el5
subscription-manager-migration-data-1.11.2.4-1.git.0.27879c1.el5
subscription-manager-gui-1.0.20-1.el5
subscription-manager-migration-1.0.20-1.el5

[root@dhcp193-98 /]# subscription-manager subscribe --auto --servicelevel Standard
Service level set to: Standard
Installed Product Current Status:
Product Name:         	Awesome OS Server Bits
Status:               	Subscribed

Product Name:         	Shared File System Bits
Status:               	Subscribed

[root@dhcp193-98 /]# subscription-manager list --consumed+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Shared File System
Provides:             	Shared File System Bits
SKU:                  	sfs
Contract:             	127
Account:              	12331131231
Serial Number:        	4277272434092365074
Active:               	True
Quantity Used:        	1
Service Level:        	Layered
Service Type:         	
Starts:               	09/26/2012
Ends:                 	09/26/2013

Subscription Name:    	Awesome OS Server Bundled (2 Sockets, Standard Support)
Provides:             	Clustering Bits
                      	Awesome OS Server Bits
                      	Load Balancing Bits
                      	Large File Support Bits
                      	Shared Storage Bits
                      	Management Bits
SKU:                  	awesomeos-server-2-socket-std
Contract:             	36
Account:              	12331131231
Serial Number:        	1406949148075060536
Active:               	True
Quantity Used:        	1
Service Level:        	Standard
Service Type:         	L1-L3
Starts:               	09/26/2012
Ends:                 	09/26/2013


[root@dhcp193-98 /]# subscription-manager facts --list | grep system.certificate_version:
system.certificate_version: 3.0


Working fine resolving defect as verified
Comment 8 errata-xmlrpc 2013-01-08 02:18:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0039.html

Note You need to log in before you can comment on or make changes to this bug.