Bug 859680 - run-parts should catch jobs output
run-parts should catch jobs output
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: crontabs (Show other bugs)
6.3
All Linux
low Severity low
: rc
: ---
Assigned To: Marcela Mašláňová
qe-baseos-daemons
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 03:53 EDT by Vadym Chepkov
Modified: 2014-09-04 07:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 07:35:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadym Chepkov 2012-09-23 03:53:08 EDT
crontabs-1.10-33.el6.noarch

run-parts should catch output of daily/weekly/monthly jobs to create a well formatted e-mails

Currently subject of a e-mail produces by run-parts looks like this:

Cron <root@t100> [ ! -f /etc/cron.hourly/0anacron ] && run-parts /etc/cron.daily

run-parts should collect output (stdout and stderr) of the jobs it's running and not rely on cron to send e-mails, it should send e-mail explicitly, with well formed subject.
Comment 2 Marcela Mašláňová 2012-09-25 13:24:26 EDT
The subject of email could be changed, but I do not want duplicate sending of emails in run-parts script.
Comment 3 RHEL Product and Program Management 2013-10-13 20:26:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Marcela Mašláňová 2014-09-04 07:35:03 EDT
I wouldn't recommend change of behaviour in RHEL-6.

Note You need to log in before you can comment on or make changes to this bug.