Bug 859720 - Word of advice for including usb_modeswitch in RHEL 6.4
Word of advice for including usb_modeswitch in RHEL 6.4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: RHEL Product and Program Management
nobody nobody
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 10:22 EDT by Daniel Maia
Modified: 2015-09-16 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 12:46:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Maia 2012-09-23 10:22:12 EDT
People from CentOS asked me to transmit this bug report to RHEL team as well.

Description of problem:
After failing to use my 3G modem on CentOS 6.3 due to switching problems I contacted Josua Dietze (usb_modeswitch developer). He found out that the problem resides on el6 implementation of his package.
There are two corrections to make.

1) The script "/lib/udev/usb_modeswitch" must be moved and renamed to "/usr/sbin/usb_modeswitch_dispatcher"

2) His original "usb_modeswitch.sh" script is missing. A copy should be installed in "/lib/udev/", renamed as "usb_modeswitch".

Version-Release number of selected component (if applicable):
Last version

How reproducible:
Always

Steps to Reproduce:
1. Connect a 3G modem with a cdrom like partition inside
2.
3.
  
Actual results:
Modem does not switch to proper mode

Expected results:


Additional info:
Please contact usb_modeswitch developer for further info if you wish.
Comment 2 Lukáš Nykrýn 2012-09-24 03:31:32 EDT
This has to do nothing with usbutils and it seems to me that we don't have usb_modeswitch package in rhel6.
Comment 3 Daniel Maia 2012-09-24 12:09:51 EDT
I did not know to whom should I submit the report, so I ended up posting it to you. Could you please transmit it to the right person? Anyway, I guess it will not matter if you are not going to integrate usb_modeswitch into rhel 6.

Regards,
Daniel
Comment 5 RHEL Product and Program Management 2013-10-13 20:26:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Steve Almy 2015-09-16 12:46:31 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux.

We have carefully evaluated the request, but are unable to include it in Red Hat Enterprise Linux 6. To request that Red Hat re-consider this request, please re-open the bugzilla via appropriate support channels and provide additional business and/or technical details.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.