Bug 859732 - Quota calculation need to be explained
Quota calculation need to be explained
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Hildred
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 11:44 EDT by ofri
Modified: 2014-03-25 03:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 12:21:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
omasad: needinfo-


Attachments (Terms of Use)

  None (edit)
Description ofri 2012-09-23 11:44:32 EDT
Since quota calculation differs from the actual storage usege visable to the user, the quota calculation logic need to be explained.
Comment 3 Tim Hildred 2012-09-24 21:34:07 EDT
From emails from Ofri and Gilad:

> > Here is what i think is missing:
> >
> > ************************
> > Quota accounting:
> > After a quota was assigned to a costumer or a resource, each action

/s/costumer/consumer

> > by that user or on that resource that involves storage, vcpu or
> > memory will result in quota consumption or quota release. For
> > example: when a user runs a VM with 1 vcpu and 1024MB memory – the
> > action will consume 1 vcpu and 1024MB of the quota assigned to that
> > user. When The VM will be stopped 1 vcpu and 1024MB will be
> > released
> > back to the quota assigned to that user (Note that Run-time Quota
> > consumption is accounted only during the actual run-time of the
> > consumer).
> > Since the quota acts as an upper bound which limits the user's
> > resources, the quota calculations may differ from the actual
> > current
> > use of the user. The quota is calculated for the max growth
> > potential and not the current usage. For example: if a user creates
> > a virtual thin provision disk of 10GB, the actual disk usage may
> > indicate only 3GB of that disk are actually in use. The quota
> > consumption, however, would be 10GB (The max growth potential of
> > that disk).
Comment 4 Tim Hildred 2012-09-28 03:39:22 EDT
Added new topic to admin guide:
Quota Accounting [11740]
Comment 7 Tim Hildred 2012-10-07 20:57:41 EDT
Yes. And it should say virtual machine instead of VM. 

I'll fix it now. 

Moving to MODIFIED until I can stage it again.

Note You need to log in before you can comment on or make changes to this bug.