Bug 859772 - s-c-services - ERROR:dbus.proxies:Introspect error on
s-c-services - ERROR:dbus.proxies:Introspect error on
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-23 19:37 EDT by Flóki Pálsson
Modified: 2014-02-05 07:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:16:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
$ system-config-services 2> s-c-s.txt (134.84 KB, text/plain)
2012-10-13 09:31 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2012-09-23 19:37:22 EDT
Description of problem:
system-config-services does not start.

Version-Release number of selected component (if applicable):
system-config-services-0.101.8-1.fc18.noarch

How reproducible:
always 

Steps to Reproduce:
1.  $ system-config-services
2.
3.
  
Actual results:
ERROR:dbus.proxies:Introspect error on :1.3:/org/freedesktop/systemd1: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Failed: Resource temporarily unavailable
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 1274, in <module>
    UIController(use_dbus=use_dbus).run()
  File "/usr/bin/system-config-services", line 1192, in __init__
    use_polkit=use_dbus)
  File "/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py", line 65, in __init__
    self.subscribe()
  File "<string>", line 2, in subscribe
  File "/usr/lib/python2.7/site-packages/slip/dbus/polkit.py", line 141, in _enable_proxy
    return func(*p, **k)
  File "/usr/lib/python2.7/site-packages/scservices/core/systemd/manager.py", line 71, in subscribe
    return self.manager_interface.Subscribe()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/slip/dbus/proxies.py", line 50, in __call__
    return dbus.proxies._ProxyMethod.__call__(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Failed: Resource temporarily unavailable

Expected results:
To see s-c-services window

Additional info:
Comment 1 Flóki Pálsson 2012-09-24 19:46:07 EDT
works now 
system-config-services-0.101.8-1.fc18.noarch  ( same version )

I installed again DVD an updated.
Comment 2 Flóki Pálsson 2012-10-13 09:31:11 EDT
Created attachment 626550 [details]
$ system-config-services 2> s-c-s.txt

SELinix is Enforcing.
system-config-services starts but show only NetworkManager and rsync.

Works in Permissive mode.
Comment 3 Flóki Pálsson 2012-11-08 17:22:12 EST
ok now
Comment 4 Vince Radice 2012-11-21 16:39:09 EST
I had this problem along with gam-server using 100% of cpu.  I disabled the gam-server by renaming it.  Cpu usage went to normal but I got some errors about not connecting with gam-server when I tried to start s-c-services from command prompt.  Some of the posts about gam-server suggested changing its options to poll very infrequently like once an hour.  I created  a .gaminrc in my home directory with these options.  Renamed gam-server back and now it works from command line and from the administration menu.  I don't know if this helps anyone but it fixed my problem.
Comment 5 Fedora End Of Life 2013-12-21 03:55:36 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2014-02-05 07:16:47 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.