Bug 859856 - Problem including dependency in WFK-2.1 (Errai) for already productized artifact in EAP-6.0.0.GA
Problem including dependency in WFK-2.1 (Errai) for already productized artif...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Errai (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity medium
: ER1
: 2.1.0
Assigned To: Pavel SLegr
Karel Piwko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 04:24 EDT by Pavel SLegr
Modified: 2012-11-30 10:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 10:33:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel SLegr 2012-09-24 04:24:36 EDT
Description of problem:

Including dependency of hibernate-entitymanager-4.1.3.Final-redhat-1, which is already included dependency in productized EAP-6.0.0.GA version.

Already known problem, resolved upstream by
https://issues.jboss.org/browse/JBPAPP-9362


resolved with:
http://git.app.eng.bos.redhat.com/?p=errai/errai.git;a=commitdiff;h=6a94e8e621003d5a0a9a80463158ce2894a6ac96
Comment 1 Karel Piwko 2012-09-24 10:37:40 EDT
Please move this issue to ON_QA with an official release.
Comment 2 Karel Piwko 2012-09-24 10:38:25 EDT
I mean official = could be an internal build, but a one officially accepted by QE.
Comment 3 Karel Piwko 2012-11-05 04:01:06 EST
I think it would be better to use <dependencyManagement> instead of excluding transitive dependencies and adding implicit version.

Verified in WFK 2.1.0.ER2.
Comment 4 Karel Piwko 2012-11-30 10:33:56 EST
Distributed as a part of WFK 2.1.0.GA release.

Note You need to log in before you can comment on or make changes to this bug.