Bug 859864 - [Doco] Backup and restore improvements
[Doco] Backup and restore improvements
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Athene Chan
ecs-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 04:45 EDT by Lukas Zapletal
Modified: 2015-05-11 18:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:37:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-09-24 04:45:57 EDT
Hello,

CFSE backup and restore plan must be moved from Release Notes section to the 1.1 documentation:

https://access.redhat.com/knowledge/docs/en-US/CloudForms/1.0/html-single/Release_Notes/index.html#chap-Release_Notes-BackupRecovery

Additional notes:

In the Procedure 4.2. Restore Procedure after Step 1 "Prepare the System Engine host for restore" I'd like to put additional note:

Note: Do not extract all configuration files yet. To configure CloudForms, you only need one file called katello-configure.conf. It is recommended to extract configuration files into a /temp directory and using it from there:

# tar ––selinux –xzvf config_files.tar.gz –C /tmp
# katello–configure ––answer–file=/tmp/etc/katello/katello–configure.conf

Before step 5 (Restore the system files) I'd like to put this note:

Note: It is a good idea to make additional backup of configuration files before they gets overwritten from the backup. You can do this executing command from Step 2 from the Backup section (Backup the configuration and data files), so the files can be extracted and examined with a GNU diff tool if a problem occurs.
Comment 2 Lukas Zapletal 2012-09-27 03:34:41 EDT
In the Pulp backup section we have two headlines:

Option One
Option Two

Please explicitely tell the customer those are offline and online backups:

Option One: Online Pulp backup
Option Two: Offline Pulp backup

I and Og are reviewing the docs, I will update our upstream wiki https://fedorahosted.org/katello/wiki/GuideServerBackups and send a link to a diff wich changes required. Thanks.
Comment 3 Lukas Zapletal 2012-09-27 04:18:42 EDT
Required changes (also incorporated all above):

https://fedorahosted.org/katello/wiki/GuideServerBackups?action=diff&version=20&old_version=19
Comment 4 Og Maciel 2012-10-04 12:34:24 EDT
Please also incorporate the following change:

https://fedorahosted.org/katello/wiki/GuideServerBackups?action=diff&version=21&old_version=20
Comment 5 Og Maciel 2012-10-05 11:26:14 EDT
Please also incorporate the following change:

https://fedorahosted.org/katello/wiki/GuideServerBackups?action=diff&version=22&old_version=21
Comment 6 Lukas Zapletal 2012-10-08 10:51:45 EDT
Okay Og and me are finished with changes of the Backup and recovery chapter. Please incorporate our changes:

https://fedorahosted.org/katello/wiki/GuideServerBackups

you can see all the changes as simple diffs here (changes from the revision 20 until now):

https://fedorahosted.org/katello/wiki/GuideServerBackups?action=history
Comment 10 Corey Welton 2012-10-17 04:48:16 EDT
mass-move of docs-related bugs to ecs-bugs@redhat.com.

If this appears to be incorrect, feel free to bounce back to katello-qa-list@redhat.com and/or request clarification.
Comment 12 Lana Brindley 2012-11-18 21:35:25 EST
This documentation has now been dropped to translation ahead of publication. For any further issues, please open a new a bug.

LKB
Comment 13 Lana Brindley 2012-12-10 16:37:04 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB
Comment 14 Mike McCune 2013-08-16 14:16:10 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.