Bug 859874 - dracut goes into an infinite loop
dracut goes into an infinite loop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 05:09 EDT by Richard W.M. Jones
Modified: 2012-10-03 06:38 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 06:38:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (45.96 KB, image/png)
2012-09-24 05:09 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2012-09-24 05:09:33 EDT
Created attachment 616435 [details]
Screenshot

Description of problem:

NB: This is RAWHIDE not Fedora 18.

dracut goes into an infinite loop during boot.  I updated
this machine to the latest version of Rawhide over the
weekend.

Version-Release number of selected component (if applicable):

dracut 023-2.fc18
systemd 188-3.fc19
kernel 3.6.0-0.rc6.git0.2.fc18.x86_64

How reproducible:

Happens when you try to boot.

Steps to Reproduce:
1. Update a VM to the latest Rawhide on x86_64
2. Reboot it
Comment 1 Harald Hoyer 2012-09-24 09:55:36 EDT
(In reply to comment #0)
> systemd 188-3.fc19

This is the culprit... "update" systemd and regenerate the initramfs
Comment 2 Richard W.M. Jones 2012-09-24 09:57:50 EDT
There's no systemd in Rawhide to update to:

$ rpm -q systemd
systemd-188-3.fc19.x86_64
$ sudo yum update systemd
Loaded plugins: langpacks, presto
No Packages marked for Update

cf http://koji.fedoraproject.org/koji/packageinfo?packageID=10477
Comment 3 Andre Robatino 2012-09-24 16:51:19 EDT
I saw this a few days ago attempting to use any rc4, rc5, or rc6 kernel in Rawhide. But rc3 or below worked for me.
Comment 4 Andre Robatino 2012-09-25 23:43:58 EDT
The rc7 non-debug kernel works for me, as does rc3. The rc4, rc5, and rc6 non-debug kernels, and kernel 3.6.0-0.rc6.git0.2.fc18.x86_64, go into the infinite loop.

dracut-023-39.git20120910.fc18.x86_64
systemd-188-3.fc18.x86_64
Comment 5 Andre Robatino 2012-09-25 23:45:26 EDT
Should also mention that all the non-debug kernels work fine on F18. The infinite loop only appears in Rawhide, and only with rc4, rc5, and rc6.
Comment 6 Andre Robatino 2012-10-03 05:10:52 EDT
I'm not seeing this with any of the more recent kernels, either. This can probably be closed unless someone else is still seeing it.

Note You need to log in before you can comment on or make changes to this bug.