This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 859977 - Systems > $system > Content > Packages: Errors should bubble up to the system notification level
Systems > $system > Content > Packages: Errors should bubble up to the syste...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 10:28 EDT by Corey Welton
Modified: 2014-03-18 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2012-09-24 10:28:17 EDT
Description of problem:

Failure of a Package Group (and/or likely just a Package itself) only appears in a small portion of the UI pane itself. Such errors should bubble up to the notifications layer.

Version-Release number of selected component (if applicable):
CloudForms System Engine Version: 1.1.12-7.el6cf

How reproducible:
Every time (if you can force an error, which, well, pretty much happens for me every time)

Steps to Reproduce:
1.  Register a system and sync/promote relevant content
2.  Systems > $system > Content >  Packages
3.  Chose Package Groups radio button
4.  Enter "Development Tools" in the field and +Add
5.  Do something that would cause the remote system to fail to get packages, such as power off, kill network, etc.
6. Submit; wait for eventual timeout
 
Actual results:
"Add Package Group Error"; clicking this provides some minor detail about failure. However, these errors do not bubble up to the larger Notifications UI.  The message about scheduling it does, but the results (failure and probably pass) do not.

Expected results:
These messages should bubble up to Notification UI

Additional info:
Comment 1 Mike McCune 2014-03-18 13:38:00 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.