Bug 860088 - [de_DE] translation for a url should not be altered
[de_DE] translation for a url should not be altered
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Engineering Localization bugs mailing list
Entitlement Bugs
: Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-24 18:38 EDT by John Sefler
Modified: 2013-01-07 23:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:03:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0033 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-01-08 03:38:27 EST

  None (edit)
Description John Sefler 2012-09-24 18:38:49 EDT
Description of problem:
The tranlation for the msgid below should NOT end in a period since it affects the url:

msgid "Tip: Forgot your login or password? Look it up at http://red.ht/lost_password"
msgstr "Tipp: Login oder Passwort vergessen? Hier erhalten Sie Hilfe: http://red.ht/lost_password."

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel59 consumer]# msgunfmt --no-wrap /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo | grep -i "http://red.ht/lost_password" -A1
msgid "Tip: Forgot your login or password? Look it up at http://red.ht/lost_password"
msgstr "Tipp: Login oder Passwort vergessen? Hier erhalten Sie Hilfe: http://red.ht/lost_password."

  
Actual results:
msgstr "Tipp: Login oder Passwort vergessen? Hier erhalten Sie Hilfe: http://red.ht/lost_password."

Expected results:
msgstr "Tipp: Login oder Passwort vergessen? Hier erhalten Sie Hilfe: http://red.ht/lost_password"
Comment 1 John Sefler 2012-09-24 18:39:25 EDT
[root@jsefler-rhel59 consumer]# rpm -q subscription-manager
subscription-manager-1.0.19-1.git.13.a2c0413.el5
Comment 2 RHEL Product and Program Management 2012-09-24 18:48:12 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Adrian Likins 2012-09-27 10:30:53 EDT
commit 82e03241bbfaaa9d498302de5d2f1846a1e55b8c
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Sep 26 17:17:06 2012 -0400

    860088: remove trailing '.' from de_DE translated urls
Comment 6 John Sefler 2012-10-05 10:49:09 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-managersubscription-manager-1.0.21-1.el5

[root@jsefler-rhel59 ~]# msgunfmt --no-wrap /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo | grep -i "http://red.ht/lost_password" -A1
msgid "Tip: Forgot your login or password? Look it up at http://red.ht/lost_password"
msgstr "Tipp: Login oder Passwort vergessen? Hier erhalten Sie Hilfe: http://red.ht/lost_password"


VERIFIED: The final period was removed from translated msgstr preventing interference with the embedded url.
Comment 7 John Sefler 2012-10-09 09:53:48 EDT
Moving back to NEW

Strangely the fix was clobbered in this continuous integration build following the build verified in comment 6.

[root@jsefler-59server ~]# rpm -q subscription-manager
subscription-manager-1.0.21-1.git.17.8374bf1.el5


[root@jsefler-59server ~]# msgunfmt --no-wrap /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo | grep -i "http://red.ht/lost_password" -A1
msgid "Tip: Forgot your login or password? Look it up at http://red.ht/lost_password"
msgstr "Tipp: Login oder Passwort vergessen? Hier erhalten Sie Hilfe: http://red.ht/lost_password."

THE TRAILING PERIOD IN THE URL OF THE TRANSLATION IS BACK FOR REVENGE.
Comment 8 Adrian Likins 2012-10-09 11:22:01 EDT
commit 8720fc26bff41f0ed342c7af9d33094253bca7eb
Author: Adrian Likins <alikins@redhat.com>
Date:   Tue Oct 9 11:09:42 2012 -0400

    latest strings and latest fixups of strings from zanata


Should fix it back. 

We had changes to po's in our tree that weren't pushed back to
zanata since it's broken atm, so the latest po pull overwrote
those changes.
Comment 10 John Sefler 2012-10-09 18:48:58 EDT
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.22-1.el5

[root@jsefler-rhel59 ~]# msgunfmt --no-wrap /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo | grep -i "http://red.ht/lost_password" -A1
msgid "Tip: Forgot your login or password? Look it up at http://red.ht/lost_password"
msgstr "Tipp: Login oder Passwort vergessen? Hier erhalten Sie Hilfe: http://red.ht/lost_password"

VERIFIED: The final period was removed from translated msgstr preventing interference with the embedded url.
Comment 12 errata-xmlrpc 2013-01-07 23:03:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.