Bug 860128 - RFE-[WebTrans] Save Failed should return human readable message instead of error code
RFE-[WebTrans] Save Failed should return human readable message instead of e...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.0
Assigned To: Patrick Huang
Alex Eng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 00:00 EDT by Ding-Yi Chen
Modified: 2013-02-25 22:46 EST (History)
4 users (show)

See Also:
Fixed In Version: Zanata version 2.0.3-SNAPSHOT (20121127-1451)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-09-25 00:00:25 EDT
Description of problem:
In WebTrans, connection lost causes "Save Failed: 0"

Howerer The number here is not very intuitive, as they are likely be misinterpreted as either row number or some unexpected error.

It will be better to show something like "Save Failed: Lost Connection"

Version-Release number of selected component (if applicable):
Zanata version 1.8.0-SNAPSHOT (20120925-0027)

How reproducible:
Always

Steps to Reproduce:
0. (Optional) install a web site blocker add-on on your browser
1. Visit any document
2. Copy source on any row
3. Disconnect the web site by either disable the network, or block the zanata server.
4. Save the copied text
  
Actual results:
Save Failed: 0

Expected results:
Save Failed: Lost Coonection
Comment 1 Patrick Huang 2012-11-15 01:34:55 EST
It's covered by bug 873483
Comment 2 Alex Eng 2012-11-26 23:42:08 EST
Fix only apply in 2.1-SNAPSHOT but not 2.0.3-SNAPSHOT.
Reassigned
Comment 3 Sean Flanigan 2012-11-26 23:52:19 EST
Patrick, is this supposed to be a duplicate of bug 873483?  That bug was verified for 2.0, so how can it be broken here?

If the code change was not in fact applied to the release branch, I think we should just change the Target Release to 2.1.
Comment 4 Patrick Huang 2012-11-26 23:53:03 EST
committed into release:
https://github.com/zanata/zanata/commit/950ed6efbf55443a21274cf73bf0737f7f8d079a
Comment 5 Patrick Huang 2012-11-26 23:56:59 EST
(In reply to comment #3)
> Patrick, is this supposed to be a duplicate of bug 873483?  That bug was
> verified for 2.0, so how can it be broken here?
> 
> If the code change was not in fact applied to the release branch, I think we
> should just change the Target Release to 2.1.

bug 873483 is for general RPC exception handling. This bug is specific to save failure. Before above commit, save failure notification still shows: "Save failure: 0" among other notification suggesting connection has lost. Now it should simply state: "Save failure: id 123"
Comment 6 Alex Eng 2012-11-27 00:39:17 EST
Verified in Zanata version 2.0.3-SNAPSHOT (20121127-1451)

Note You need to log in before you can comment on or make changes to this bug.