Bug 860130 - check power status at the end of each power command
check power status at the end of each power command
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
low Severity unspecified (vote)
: 0.10.0
: ---
Assigned To: Nick Coghlan
Provisioning
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 00:13 EDT by Dan Callaghan
Modified: 2018-02-05 19:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 859400
Environment:
Last Closed: 2012-11-22 01:43:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-09-25 00:13:35 EDT
Most fence commands support checking the power status of the system. As an extra sanity check, we could update the power scripts to do this after issuing a power command and bail out if the state is not what we are expecting.

+++ This bug was initially created as a clone of Bug #859400 +++

Description of problem:
The reboot command in beaker-provision has no delay between the off and on operation which causes some systems to hang.  Worse yet, it is not very nice to hardware and could damage it.

--- Additional comment from pasimon@redhat.com on 2012-09-24 18:22:33 EST ---

Can i suggest run status command after power command just to be sure that everything is working as expected.
Comment 1 Nick Coghlan 2012-10-31 03:45:52 EDT
It turns out waiting for the reported power status to change is already built in to the fence scripts (see /usr/share/fence/fencing.py), so it will only make sense to do this for the ipmitool and virsh power scripts.

This is similar to the "don't issue the command if we're already in the correct state" checks, which are implicit in all fence scripts, but need to be handled explicitly for virsh and ipmitool.
Comment 2 Nick Coghlan 2012-11-01 03:52:44 EDT
I ended up just modifying ipmitool for now.

http://gerrit.beaker-project.org/#/c/1460/
Comment 3 Raymond Mancy 2012-11-22 01:43:52 EST
This has now been released

Note You need to log in before you can comment on or make changes to this bug.