Bug 860219 - Installing Enterprise Web Server on Windows - chapter 3
Installing Enterprise Web Server on Windows - chapter 3
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-Installation-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 05:46 EDT by Libor Fuka
Modified: 2012-11-08 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Fuka 2012-09-25 05:46:47 EDT
Description of problem:

Please change C:\Program Files\Red Hat\Enterprise Web Server to C:\Program Files\jboss-ews-2.0 in all chapters Installing Enterprise Web Server on Windows

We rae not certifying with Windows 2003 but only with Windows Server 2008 and Windows Server 2008R2

Chapter 3.1
===========
"Download JDK 1.6 for your operating system from the web site." shoudl be "Download JDK 1.6 for your operating system and right architecture from the web site." - we also support JDK 1.7, so ask Mladen, Weinan what should be in DOC. May be something like "JDK 1.6 or JDK 1.7"

Install APR note - please delete this

Chapter 3.2
==============
Its not extracted to C:\Program Files\Red Hat\Enterprise Web Server but to
C:\Program Files\jboss-ews-2.0

Its not C:\Program Files\Red Hat\Enterprise Web Server\etc\httpd\conf but 
C:\Program Files\jboss-ews-2.0\etc\httpd\conf

Chapter 3.3
==============
Do not use yellow color  for "Do Not Use the -d Option to Start httpd on Windows". Its not readable
I don't understand this sentence "The -d option is used when a new configuration is created in the same location and the configuration must be tested. " - please verify with Mladen Turk

Running Command Prompt in Windows Server 2003 - Its not supported platform - DELETE

"C:\Program Files\Red Hat\Enterprise Web Server\etc" shoudl be "C:\Program Files\jboss-ews-2.0\etc"

"call postinstall.bat" should be 2 commands "call postinstall.httpd.bat" and "call postinstall.tomcat.bat"

C:\> cd /D "C:\Program Files\Red Hat\Enterprise Web Server\sbin" completly wrong. It must be this:
- for tomcat6: C:\> cd /D "C:\Program Files\jboss-ews-2.0\share\tomcat6\bin" and then call service.bat install
- for tomcat7: C:\> cd /D "C:\Program Files\jboss-ews-2.0\share\tomcat7\bin" and then call service.bat install

Its not C:\Program Files\Red Hat\Enterprise Web Server\extras\ to C:\Program Files\jboss-ews-2.0\share\extras\

We have tomcat6 and tomcat7 not tomcat5

Create the file C:\Program Files\Red Hat\Enterprise Web Server\etc\httpd\conf\JBoss_HTTP.conf. -> Create the file C:\Program Files\jboss-ews-2.0\etc\httpd\conf.d\mod_cluster-native.conf. (you can use sample from etc\httpd\conf)

Select the Security tab.
Click the Add.. button and type in LOCAL SERVICE.  -> there is no Add button -> verify on windows, should be Edit->Add

Its not dir Red Hat but jboss-ews-2.0

Repair to: Change premissions -> select the Replace permissions on all child objects...











Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Libor Fuka 2012-09-25 06:40:04 EDT
Chapter 3.4
===============
net start httpd -> must be net start Apache2.2

In the Services dialog, right-click the name of the service (Apache2.2 or Apache Tomcat 6 or Apache Tomcat 7)

libeay32.dil -> libeay32.dll => check all dll names in the Note

Chapter 3.5
==============
net stop Apache2.2
(Apache2.2 or Apache Tomcat 6 or Apache Tomcat 7)

Chapter 3.6
==============
Structure is diff than reality - Check it all with xxxwin.zip
Comment 2 Misha H. Ali 2012-09-26 03:15:17 EDT
(In reply to comment #0)
> Description of problem:
> 
> Please change C:\Program Files\Red Hat\Enterprise Web Server to C:\Program
> Files\jboss-ews-2.0 in all chapters Installing Enterprise Web Server on
> Windows
> 

Done. All instances are now C:\Program File\jbowss-ews-2.0

> We rae not certifying with Windows 2003 but only with Windows Server 2008
> and Windows Server 2008R2
> 

Added a note (marked important) to the beginning of the Install EWS with Windows chapter.

> Chapter 3.1
> ===========
> "Download JDK 1.6 for your operating system from the web site." shoudl be
> "Download JDK 1.6 for your operating system and right architecture from the
> web site." - we also support JDK 1.7, so ask Mladen, Weinan what should be
> in DOC. May be something like "JDK 1.6 or JDK 1.7"
> 

For now I have added 1.7 as well.

Adding Mladen and Weinan as cc for this bug so they can confirm if 1.7 is supported.

> Install APR note - please delete this
> 

I think it was Weinan who recommended this should be included. Weinan, can you confirm if the Install APR note is not required for Tomcat Native here.

> Chapter 3.2
> ==============
> Its not extracted to C:\Program Files\Red Hat\Enterprise Web Server but to
> C:\Program Files\jboss-ews-2.0
> 
> Its not C:\Program Files\Red Hat\Enterprise Web Server\etc\httpd\conf but 
> C:\Program Files\jboss-ews-2.0\etc\httpd\conf
> 

These should be OK now.

> Chapter 3.3
> ==============
> Do not use yellow color  for "Do Not Use the -d Option to Start httpd on
> Windows". Its not readable

The yellow is just to highlight changes. It will be removed after the bugs are verified.0

> I don't understand this sentence "The -d option is used when a new
> configuration is created in the same location and the configuration must be
> tested. " - please verify with Mladen Turk
> 

Mladen, need your input here.

> Running Command Prompt in Windows Server 2003 - Its not supported platform -
> DELETE
> 

This is now removed.

> "C:\Program Files\Red Hat\Enterprise Web Server\etc" shoudl be "C:\Program
> Files\jboss-ews-2.0\etc"
> 

Gone.

> "call postinstall.bat" should be 2 commands "call postinstall.httpd.bat" and
> "call postinstall.tomcat.bat"
> 

Fixed. 

> C:\> cd /D "C:\Program Files\Red Hat\Enterprise Web Server\sbin" completly
> wrong. It must be this:
> - for tomcat6: C:\> cd /D "C:\Program Files\jboss-ews-2.0\share\tomcat6\bin"
> and then call service.bat install
> - for tomcat7: C:\> cd /D "C:\Program Files\jboss-ews-2.0\share\tomcat7\bin"
> and then call service.bat install
> 

Fixed.

> Its not C:\Program Files\Red Hat\Enterprise Web Server\extras\ to C:\Program
> Files\jboss-ews-2.0\share\extras\
> 

Fixed.

> We have tomcat6 and tomcat7 not tomcat5
> 

What is the equivalent of this for Tomcat 7? Tomcat 5 is now removed. Mladen, Weinan, can either of you help?

> Create the file C:\Program Files\Red Hat\Enterprise Web
> Server\etc\httpd\conf\JBoss_HTTP.conf. -> Create the file C:\Program
> Files\jboss-ews-2.0\etc\httpd\conf.d\mod_cluster-native.conf. (you can use
> sample from etc\httpd\conf)
> 

Changed file name and location but need guidance about the lined to paste into the file. Mladen, Weinan? (Ref: Procedure 3.11. Configuring mod_cluster, Step 2a).

> Select the Security tab.
> Click the Add.. button and type in LOCAL SERVICE.  -> there is no Add button
> -> verify on windows, should be Edit->Add
> 

Fixed.

> Its not dir Red Hat but jboss-ews-2.0
> 

Not specific but I think I have gotten all references to dir Red Hat so fixed.

> Repair to: Change premissions -> select the Replace permissions on all child
> objects...
> 

Not sure if I understood this one correctly. Please clarify if incorrect.
Comment 3 Misha H. Ali 2012-09-26 04:06:26 EDT
(In reply to comment #1)
> Chapter 3.4
> ===============
> net start httpd -> must be net start Apache2.2
> 

Fixed.

> In the Services dialog, right-click the name of the service (Apache2.2 or
> Apache Tomcat 6 or Apache Tomcat 7)
> 

Added.

> libeay32.dil -> libeay32.dll => check all dll names in the Note
> 
> Chapter 3.5
> ==============
> net stop Apache2.2
> (Apache2.2 or Apache Tomcat 6 or Apache Tomcat 7)
> 

Fixed as above.

> Chapter 3.6
> ==============
> Structure is diff than reality - Check it all with xxxwin.zip

Can someone confirm that this is the correct new structure? (ref: jboss-ews-http...win.zip):

bin
etc
 |_httpd
      |_conf
      |_conf.d
 |_krb5
 |_ssl
      |_CA
      |_certs
      |_private
lib64
 |_httpd
sbin
share
 |_doc
   |_db4-4.3.29
   |_httpd-2.2.22
   |_krb5-1.9
      |_doc
         |_api
         |_implement
         |_kadm5
   |_libiconv-1.14
   |_mod_auth_kerb-5.4
   |_mod_cluster-native-1.2.2
   |_mod_jk-1.2.36
   |_openssl-0.9.8e
        |_apps
   |_zlib-1.2.3
var
   |_www
        |_cgi-bin
        |_error
            |_include
        |_html
        |_icons
            |_small
        |_manual
            |_developer
            |_faq
            |_howto
            |_images
            |_misc
            |_mod
            |_platform
            |_programs
            |_rewrite
            |_ssl
            |_style
            |_vhosts
Comment 4 Jean-frederic Clere 2012-10-03 05:16:44 EDT
lib64
 |_httpd
        |_modules

it is lib for i386 and lib64 for x64_64

the rest looks ok.
Comment 5 Misha H. Ali 2012-10-04 02:36:55 EDT
The comment is a bit convoluted so here are some snips of what I still need information for:

> > Chapter 3.1
> > ===========
> > "Download JDK 1.6 for your operating system from the web site." shoudl be
> > "Download JDK 1.6 for your operating system and right architecture from the
> > web site." - we also support JDK 1.7, so ask Mladen, Weinan what should be
> > in DOC. May be something like "JDK 1.6 or JDK 1.7"
> > 
> 
> For now I have added 1.7 as well.
> 

Need someone to confirm whether JDK 1.7 should also be mentioned when asking users to download JDK 1.6.

> > Install APR note - please delete this
> > 
> 

I believe it was Weinan who originally pointed me towards adding this information, so I'd like his confirmation about it not being necessary anymore.

> > Chapter 3.3
> > ==============

> 
> > I don't understand this sentence "The -d option is used when a new
> > configuration is created in the same location and the configuration must be
> > tested. " - please verify with Mladen Turk
> > 
 
Mladen, need your input here.

> 
> > Create the file C:\Program Files\Red Hat\Enterprise Web
> > Server\etc\httpd\conf\JBoss_HTTP.conf. -> Create the file C:\Program
> > Files\jboss-ews-2.0\etc\httpd\conf.d\mod_cluster-native.conf. (you can use
> > sample from etc\httpd\conf)
> > 
> 

Need guidance about the lines to paste into the file. Mladen, Weinan? (Ref: Procedure 3.11. Configuring mod_cluster, Step 2a).
Comment 6 Jean-frederic Clere 2012-10-04 02:50:56 EDT
According to QE plan they should test JDK 1.7. So yes JDK 1.7 must be in the docs.

The APR installation part must be removed: it comes from an old doc (because of RHEL4. It had apr 0.9).
Comment 8 Misha H. Ali 2012-10-07 20:45:19 EDT
(In reply to comment #7)
> for Chap 3.3:
> 
> We should not document the -d option see:
> https://issues.jboss.org/browse/JBPAPP-
> 9491?focusedCommentId=12710156&page=com.atlassian.jira.plugin.system.
> issuetabpanels:comment-tabpanel#comment-12710156

Jean-Frederic, from Mladen's comment I understand that he thinks we should document it but mention that it's just a tip for a specific scenario. Based on your comment above, if I am understanding you correctly, this should not be documented at all. 

Just to clarify, is this a supported option we should include as a a tip or trick sort of thing for Windows as Mladen suggests in the bug, or should this not be documented at all (possibly because it is dangerous or unsupported)?
Comment 9 Misha H. Ali 2012-10-07 21:02:50 EDT
The following changes are made:

1. APR information is now removed for Win and Solaris installations.
2. Update reference to download JDK 1.6 for Win and Solaris installations to instructions to download JDK 1.6 or 1.7 and the corresponding architecture, as suggested.

Unsure about the -d information, waiting for clarification before making the required changes and setting this bug to MODIFIED.
Comment 10 Mladen Turk 2012-10-08 01:34:39 EDT
(In reply to comment #8)
> 
> Jean-Frederic, from Mladen's comment I understand that he thinks we should
> document it but mention that it's just a tip for a specific scenario. Based
> on your comment above, if I am understanding you correctly, this should not
> be documented at all. 
> 

Yes, it should not be documented.

> Just to clarify, is this a supported option we should include as a a tip or
> trick sort of thing for Windows as Mladen suggests in the bug, or should
> this not be documented at all (possibly because it is dangerous or
> unsupported)?

The tip I was referring was to be used for support in case they got a question from client why -d option behaves differently.
Ans: 
It behaves differently to be able to have the same directory layout like on RHEL.

So it's really not something that should go into the general documentation. The "tip" form in documentation would just confuse users making them believe they should use -d option, while the truth is that this option is strongly discouraged. Hence the tip for the support why it's discouraged.

Hope my comment makes sense :)
Comment 11 Libor Fuka 2012-10-08 05:17:35 EDT
Checking again chpater 3. Installing Enterprise Web Server on Windows
and found these problems:

1. Chapter 3.8. Configuring log4j doesn't corespond EWS zip structure
2. 3.10 In C:\Program Files\jboss-ews-2.0\etc\httpd\conf.d\, -> remove ,
3. Chapter 3.12 Security Settings should be rewritten to fit Win 2008 steps. 
4. Chapter 3.6 doesn't fit full EWS20 zip directory structure, including symbolic links

Regarding 3. and 4. Have you access to some MS Win 2008 server ?
Comment 12 Misha H. Ali 2012-10-10 01:41:12 EDT
So, to recap the issues we are dealing with in this bug:

1. The -d option is now removed. Thanks for the clarification, Mladen.

2. 
> > Create the file C:\Program Files\Red Hat\Enterprise Web
> > Server\etc\httpd\conf\JBoss_HTTP.conf. -> Create the file C:\Program
> > Files\jboss-ews-2.0\etc\httpd\conf.d\mod_cluster-native.conf. (you can use
> > sample from etc\httpd\conf)
> > 
> 

Added the following lines to replace old lines:

LoadModule proxy_cluster_module modules/mod_proxy_cluster.so
LoadModule slotmem_module modules/mod_slotmem.so
LoadModule manager_module modules/mod_manager.so
LoadModule advertise_module modules/mod_advertise.so

3. Chapter 3.8. Configuring log4j doesn't corespond EWS zip structure

Updated folder names for copy command in Solaris and RHEL installations (Tomcat 6 and 7).

4. 3.10 In C:\Program Files\jboss-ews-2.0\etc\httpd\conf.d\, -> remove ,

It was part of the sentence, but I guess it can be confusing. Removed.

5. Chapter 3.12 Security Settings should be rewritten to fit Win 2008 steps. 

Do not have Win 2008 machine set up to test this. Need an SME to identify incorrect steps. Libor, can anyone from your team who tests Win 2k8 identify this?

6. Chapter 3.6 doesn't fit full EWS20 zip directory structure, including symbolic links

Updated this, should be correct now according to CR1.
Comment 13 Misha H. Ali 2012-10-10 02:39:51 EDT
Libor, if you have some time, can I ask you or your team to verify points 1, 2, 3, 4 and 6 so we can mark them resolved (or assigned again) and focus on the remaining Win 2k8 issue?
Comment 14 Libor Fuka 2012-10-10 02:54:47 EDT
1. You mention removing yellow color ?
2. I don't know waht you mean
3. still persists
4. don't removed
5. i will send you 
6. Bad - i will send you full directory tree

Misha, please, can you double check what you did, before you ask us ?
There are smae problems and we are checking again and again.
Comment 15 Libor Fuka 2012-10-10 03:58:48 EDT
6. directory structure from Win ...httpd.zip and application-servers.zip + 
these symbolic links created after both postinstall.bat runs:

jboss-ews-2.0\etc\httpd\logs
jboss-ews-2.0\etc\httpd\modules
jboss-ews-2.0\etc\httpd\run

jboss-ews-2.0\share\tomcat6
jboss-ews-2.0\share\tomcat7

jboss-ews-2.0\share\apache-tomcat-6.0.35\logs
jboss-ews-2.0\share\apache-tomcat-6.0.35\temp
jboss-ews-2.0\share\apache-tomcat-6.0.35\work

jboss-ews-2.0\share\apache-tomcat-7.0.30\logs
jboss-ews-2.0\share\apache-tomcat-7.0.30\temp
jboss-ews-2.0\share\apache-tomcat-7.0.30\work
Comment 16 Libor Fuka 2012-10-10 04:08:39 EDT
5. Chapter 3.12 Security settings

Follow this procedure to ensure that the account used to run the services has full control over the C:\Program Files\jboss-ews-2.0 folder and all of its subfolders:

    Right-click the C:\Program Files\jboss-ews-2.0 folder and click Properties.

    Select the Security tab.

    Click the Edit button and then the Add.. button and type in LOCAL SERVICE.

    Select the Full Control check box for the new LOCAL SERVICE account.
    
    Click OK

    Click the Advanced button.

    Inside the Advanced Security Settings, select LOCAL SERVICE and click Edit
    
    Select "Replace all existing inheritable permissions on all descendants with inheritable permissions from this object" check box
    
    Click OK 
    Click OK
    Click OK 
   
    This procedure is intended for Windows 2008. The equivalent procedure in  Windows Server 2008R2 can slightly differ.
Comment 17 Misha H. Ali 2012-10-10 22:00:27 EDT
My apologies, Libor. Apparently the stage did not refresh in an hour, as usual, but took a bit longer. As a result you saw unchanged versions of the above. I should have stayed a bit longer and ensure the updated version was on the stage, so my apologies once again.

I'll update the comments you have provided and ensure the changes are on the stage before setting this bug to ON_QA.
Comment 18 Libor Fuka 2012-10-12 03:48:57 EDT
Chapter 3.8. Configuring log4j doesn't corespond EWS zip structure
C:\Program Files\jboss-ews-2.0\extras\ -> C:\Program Files\jboss-ews-2.0\share\extras\
Comment 19 Misha H. Ali 2012-10-15 23:40:48 EDT
(In reply to comment #15)
> 6. directory structure from Win ...httpd.zip and application-servers.zip + 
> these symbolic links created after both postinstall.bat runs:
> 
> jboss-ews-2.0\etc\httpd\logs
> jboss-ews-2.0\etc\httpd\modules
> jboss-ews-2.0\etc\httpd\run
> 
> jboss-ews-2.0\share\tomcat6
> jboss-ews-2.0\share\tomcat7
> 
> jboss-ews-2.0\share\apache-tomcat-6.0.35\logs
> jboss-ews-2.0\share\apache-tomcat-6.0.35\temp
> jboss-ews-2.0\share\apache-tomcat-6.0.35\work
> 
> jboss-ews-2.0\share\apache-tomcat-7.0.30\logs
> jboss-ews-2.0\share\apache-tomcat-7.0.30\temp
> jboss-ews-2.0\share\apache-tomcat-7.0.30\work

Added note about this being the symbolic structure after postinstall.bat runs and amended to the following:

jboss-ews-2.0
    |
    |-- etc
         |-- httpd
               |-- logs
               |-- modules
               '-- run
    |-- share
         |-- tomcat6
         |-- tomcat7
         |-- apache-tomcat-6.0.35
                |-- logs
                |-- temp
                '-- work
         |-- apache-tomcat-7.0.30
                |-- logs
                |-- temp
                '-- work
Comment 20 Misha H. Ali 2012-10-16 00:01:37 EDT
(In reply to comment #18)
> Chapter 3.8. Configuring log4j doesn't corespond EWS zip structure
> C:\Program Files\jboss-ews-2.0\extras\ -> C:\Program
> Files\jboss-ews-2.0\share\extras\


Updated the two references in this procedure. However, according to the above structure, there is no such folder as lib in share\tomcat6. Can you tell me the correct location the log4j files should be copied instead of the non existant lib directory, Libor?
Comment 21 Misha H. Ali 2012-10-16 00:05:34 EDT
Libor there are a few other instances in this chapter that are incorrect now that I see your corrected structure, so I'll open a new bug to track it to reduce complexity in this bug.
Comment 22 Jean-frederic Clere 2012-10-16 02:39:33 EDT
the location for the log4j files are C:\Program Files\jboss-ews-2.0\share\extras\
in the delivery. They need to go to C:\Program Files\jboss-ews-2.0\tomcat6\lib\

In fact it is not tomcat6 but apache-tomcat-6.0.x (x is the version of the ASF tomcat we are using).
Comment 23 Jean-frederic Clere 2012-10-16 03:02:00 EDT
"In fact it is not tomcat6 but apache-tomcat-6.0.x (x is the version of the ASF tomcat we are using)". forget that.

There is a symlink created by the postinstall so the doc looks OK.
Comment 24 Misha H. Ali 2012-10-16 23:47:58 EDT
Thanks, Jean-Frederic. So, to recap, elaborating on the list I created before with clarifications to help verify changes.

 
> 1. The -d option is now removed. Thanks for the clarification, Mladen.
> 

This refers to the note that explained how -d is used. The note is no longer in the docs as both Mladen and Jean-Frederic confirmed it should not be there.

> 2. 
> > > Create the file C:\Program Files\Red Hat\Enterprise Web
> > > Server\etc\httpd\conf\JBoss_HTTP.conf. -> Create the file C:\Program
> > > Files\jboss-ews-2.0\etc\httpd\conf.d\mod_cluster-native.conf. (you can use
> > > sample from etc\httpd\conf)
> > > 
> > 
> 
> Added the following lines to replace old lines:
> 
> LoadModule proxy_cluster_module modules/mod_proxy_cluster.so
> LoadModule slotmem_module modules/mod_slotmem.so
> LoadModule manager_module modules/mod_manager.so
> LoadModule advertise_module modules/mod_advertise.so
> 

Libor, this is from your feedback in comment#0. The lines above should now be in the docs and valid. Can be verified here:

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/sec-Configuring_the_Environment-Win.html

(Procedure 3.12.)

> 3. Chapter 3.8. Configuring log4j doesn't corespond EWS zip structure
> 
> Updated folder names for copy command in Solaris and RHEL installations
> (Tomcat 6 and 7).

This should be OK now. Verifiable here:

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/sec-Configuring_the_Environment-Linux-ZIP.html

(Procedure 2.10.)
 
> 4. 3.10 In C:\Program Files\jboss-ews-2.0\etc\httpd\conf.d\, -> remove ,
> 
> It was part of the sentence, but I guess it can be confusing. Removed.
> 

This was just removing a ,. Can be verified here:

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/sec-Configuring_the_Environment-Win.html

(Procedure 3.10.)

> 5. Chapter 3.12 Security Settings should be rewritten to fit Win 2008 steps. 
> 

This is now done, thanks to Libor's step correction. Can be verified here:

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/sec-Configuring_the_Environment-Win.html

(at the bottom, Procedure 3.12.)

> 
> 6. Chapter 3.6 doesn't fit full EWS20 zip directory structure, including
> symbolic links
> 
Updated with the symbolic information provided. Can be verified here:

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/sec-Directory_Structure-Win.html
Comment 25 Libor Fuka 2012-10-18 09:01:36 EDT
Checked cahpter 3. again all and i found these bugs:
=====================================================
1. (1.6 U24 and 1.7) - remove U24
2. chapter 3.3 run the post-installation scripts (they are two)
3. 3.6 bad - specify right postinstall scripts. Directory structure looks good. 

Other looks good.
Comment 26 Misha H. Ali 2012-10-18 21:22:34 EDT
All the above are now fixed. A little unsure about 3, so listed full names of both postinstall scripts and hopefully that is what was intended by #3.

(In reply to comment #25)
> Checked cahpter 3. again all and i found these bugs:
> =====================================================
> 1. (1.6 U24 and 1.7) - remove U24

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/ch-Installing_EWS_on_Windows.html

> 2. chapter 3.3 run the post-installation scripts (they are two)

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/sec-Configuring_the_Environment-Win.html

> 3. 3.6 bad - specify right postinstall scripts. Directory structure looks
> good. 

Can be verified here: http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/sec-Directory_Structure-Win.html
Comment 27 Libor Fuka 2012-10-19 02:43:26 EDT
Is OK!
Verified.
Comment 28 Misha H. Ali 2012-11-08 17:11:01 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.