Bug 860220 - libgfapi: glfs_init() takes a long time to complete
libgfapi: glfs_init() takes a long time to complete
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anand Avati
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 05:50 EDT by Bharata B Rao
Modified: 2015-09-01 19:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:39:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bharata B Rao 2012-09-25 05:50:01 EDT
Description of problem:
glfs_init() takes about 4s to complete for a local brick and server. This appears a bit too high for QEMU usecase.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2012-09-25 20:17:10 EDT
Patch posted - http://review.gluster.org/3994
Comment 2 Bharata B Rao 2012-09-25 23:45:09 EDT
(In reply to comment #1)
> Patch posted - http://review.gluster.org/3994

Verified that this patch speeds up the boot process of QEMU with GlusterFS backend significantly.
Comment 3 Niels de Vos 2014-04-17 07:39:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.