This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 860231 - [eap6] newly deployed war through JON CLI is not discovered
[eap6] newly deployed war through JON CLI is not discovered
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.0
Unspecified Unspecified
high Severity high
: ---
: JON 3.1.2
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 07:05 EDT by bkramer
Modified: 2013-09-11 06:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 860233
: 860233 (view as bug list)
Environment:
Last Closed: 2013-09-11 06:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2012-09-25 07:05:17 EDT
Description of problem:
Using JON CLI, newly created war file was "promoted" to the server-group of the eap6. That worked fine and the result of the operation was successful. Also, the server.log file showed successful deployment. However, deployed war file was not discovered and not added into inventory. The log file showed the following message:

...
"TRACE [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- No need to prepare the activation of resource Resource[id=29821, uuid=c757a5a1-739c-4ebf-b035-011ce532219a, type={JBossAS7}DomainDeployment, key=deployment=helloworld, name=helloworld, parent=EAP Domain Controller (127.0.0.1:9990)] - its component is already started and its plugin config has not been updated since it was last started."
...

After more then one hour, and after "discovery -f" was performed, the war file was discovered and added into ManagedServerDeployments. 

Version-Release number of selected component (if applicable):
JON 3.1
EAP 6.0 (domain mode)

How reproducible:
Every time.

Steps to Reproduce:
1. import EAP6 in domain mode; 
2. create new DomainDeployment for EAP 6.0 using JON UI;
3. use JON CLI and "scheduleResourceOperation" method to promote war file to the server-group;
 
  
Actual results:
Deployment is properly done but promoted war file is not discovered and it's not added in the inventory.

Expected results:
Promoted war file is properly discovered and added into inventory

Additional info:
Discovery of the war file was performed after "discovery -f" was executed from the JON Agent command line.
Comment 3 Heiko W. Rupp 2012-12-03 06:42:41 EST
This is independent of the CLI.

Promotion is an operation and does not trigger a discovery scan in JON.

Having said that, as the promote operation runs on the domain controller and this would also be the root resource for a discovery, it may be possible to implement a feature in the plugin container to trigger that scan. 
The plugin descriptor would need a new flag to indicate the scan required (and on which resource), as we do not want a discovery scan to happen after each operation that is executed.
Comment 4 Heiko W. Rupp 2012-12-03 11:53:17 EST
Biljana, can you confirm that this is with JBoss ON 3.1.0 ?
I think this was already fixed in 3.1.1 on Aug 14th by Stefan Negrea
( 9d66cddac5b2f0d4c , Bug 829329, master commit: 06a05b1371c1 ) , so that it made it into the 3.1.1 release which was tagged Sept 20th.
Comment 5 bkramer 2012-12-04 03:38:18 EST
(In reply to comment #4)
> Biljana, can you confirm that this is with JBoss ON 3.1.0 ?
> I think this was already fixed in 3.1.1 on Aug 14th by Stefan Negrea
> ( 9d66cddac5b2f0d4c , Bug 829329, master commit: 06a05b1371c1 ) , so that it
> made it into the 3.1.1 release which was tagged Sept 20th.

Yes, it seems ok - I have just tested this with JON 3.1.1 and it worked fine - deployment was immediately discovered.
Comment 6 Heiko W. Rupp 2012-12-04 03:55:46 EST
QA: can be closed, as the fix was already done by Stefan in JON 3.1.1 -- see previous comments.
Comment 7 Simeon Pinder 2012-12-07 01:31:36 EST
Moving to ON_QA as available for testing in ER3 or greater: https://brewweb.devel.redhat.com/buildinfo?buildID=246689
Comment 8 Armine Hovsepyan 2013-01-14 07:41:44 EST
verified on 3.1.2 CR2 (even it was fixed in 3.1.1 - just for making sure)

Note You need to log in before you can comment on or make changes to this bug.