Bug 860373 - client cannot join the multicast group at startup
client cannot join the multicast group at startup
Status: CLOSED DUPLICATE of bug 722690
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 13:38 EDT by Vlado Potisk
Modified: 2012-09-26 04:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 04:09:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2012-09-25 13:38:40 EDT
Description of problem:
ntpd fails to join the NTP network multicast group when started normally during the system startup. Restarting it manually later corrects this.

I guess the network interfaces and the routing table - especially the default route - might be not present or incomplete at the time of the ntpd start.

Version-Release number of selected component (if applicable):
ntp-4.2.6p5-2.fc17.x86_64

How reproducible:
always


Steps to Reproduce:
1. configure a multicast client
2. reboot
  
Actual results:
ntpd[946]: Listen and drop on 0 v4wildcard 0.0.0.0 UDP 123
ntpd[946]: Listen and drop on 1 v6wildcard :: UDP 123
ntpd[946]: Listen normally on 2 lo 127.0.0.1 UDP 123
ntpd[946]: Listen normally on 3 lo ::1 UDP 123
....
ntpd[937]: Listen normally on 4 multicast 224.0.1.1 UDP 123
ntpd[937]: Failed to join 224.0.1.1 socket to multicast group 224.0.1.1


Expected results:
(after a manual restart)
ntpd[5488]: Listen normally on 3 p21p1 192.168.41.253 UDP 123
ntpd[5488]: Listen normally on 4 p21p1 fe80::21f:d0ff:fea5:8e40 UDP 123
.....
ntpd[5488]: Listen normally on 6 multicast 224.0.1.1 UDP 123
ntpd[5488]: Joined 224.0.1.1 socket to multicast group 224.0.1.1


Additional info:
Note the p21p1 ethernet card network interface not present in the first log, but present in the second one.
Comment 1 Miroslav Lichvar 2012-09-26 04:09:40 EDT
I think this is the same problem as with broadcastclient in the bug #722690, the dynamic update code will need to be fixed.

*** This bug has been marked as a duplicate of bug 722690 ***
Comment 2 Vlado Potisk 2012-09-26 04:21:17 EDT
> I think this is the same problem as with broadcastclient in the bug #722690,
> the dynamic update code will need to be fixed.

Yes, indeed. I have searched the database with the "multicast" keyword, didn't find that one.

Note You need to log in before you can comment on or make changes to this bug.