This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 860408 - repo group members add with repo id adds all the repos to the group
repo group members add with repo id adds all the repos to the group
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 40
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
: 856775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 14:48 EDT by Preethi Thomas
Modified: 2013-09-09 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:04:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-09-25 14:48:30 EDT
Description of problem:
 
repo group members add with repo id adds all the repos on your pulp server to the group

Version-Release number of selected component (if applicable):

[root@pulp-master ~]# rpm -q pulp-rpm-server
pulp-rpm-server-0.0.328-1.fc17.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

[root@pulp-master ~]# pulp-admin repo group list
+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:           pulp
Display Name: None
Description:  None
Repo Ids:     855384, pulp
Notes:        

[root@pulp-master ~]#  pulp-admin repo group members remove --group-id pulp --filters='{"id":"pulp"}'
Successfully removed members from repository group [pulp]

[root@pulp-master ~]# pulp-admin repo group list+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:           pulp
Display Name: None
Description:  None
Repo Ids:     855384
Notes:        


[root@pulp-master ~]#  pulp-admin repo group members remove --group-id pulp --filters='{"id":"855384"}'
Successfully removed members from repository group [pulp]

[root@pulp-master ~]# pulp-admin repo group list+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:           pulp
Display Name: None
Description:  None
Repo Ids:     
Notes:        


[root@pulp-master ~]# pulp-admin repo group members add --group-id pulp --repo-id pulp
Successfully added members to repository group [pulp]

[root@pulp-master ~]# pulp-admin repo group list
+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:           pulp
Display Name: None
Description:  None
Repo Ids:     855384, pulp
Notes:        


Expected results:


Additional info:
Comment 1 Michael Hrivnak 2012-10-02 11:40:37 EDT
There were two problems here. One is that the --repo-id option was being ignored, so it did not impact the search. The second issue is that a search with no matching options specified would match everything, which is probably not what we want when adding and removing.
Comment 2 Michael Hrivnak 2012-10-02 14:04:56 EDT
*** Bug 856775 has been marked as a duplicate of this bug. ***
Comment 3 Preethi Thomas 2012-10-10 10:49:59 EDT
[root@pulp-master ~]# rpm -qa pulp-rpm-server
pulp-rpm-server-0.0.331-1.fc17.noarch
[root@pulp-master ~]# 

[root@pulp-master ~]# pulp-admin -u admin -p admin repo group members add --group-id pulp --repo-id pulp
Successfully added members to repository group [pulp]

[root@pulp-master ~]# pulp-admin -u admin -p admin repo group list
+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:           pulp
Display Name: None
Description:  None
Repo Ids:     pulp
Notes:        


[root@pulp-master ~]# pulp-admin -u admin -p admin repo group members add --group-id pulp --repo-id zoo
Successfully added members to repository group [pulp]

[root@pulp-master ~]# pulp-admin -u admin -p admin repo group list
+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:           pulp
Display Name: None
Description:  None
Repo Ids:     pulp, zoo
Notes:        


[root@pulp-master ~]# pulp-admin -u admin -p admin repo group members remove  --group-id pulp --filters='{"id":"zoo"}'
Successfully removed members from repository group [pulp]

[root@pulp-master ~]# pulp-admin -u admin -p admin repo group list
+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:           pulp
Display Name: None
Description:  None
Repo Ids:     pulp
Notes:        


[root@pulp-master ~]#
Comment 4 Preethi Thomas 2013-01-09 12:04:29 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.