Bug 860411 - [abrt] system-config-printer-1.3.9-1.fc17: newprinter.py:1690:start_fetching_devices:AttributeError: 'NewPrinterGUI' object has no attribute 'current_uri'
[abrt] system-config-printer-1.3.9-1.fc17: newprinter.py:1690:start_fetching_...
Status: CLOSED DUPLICATE of bug 743717
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:f304d01b52625d0fca42f864327...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 14:51 EDT by Andres Cabrera
Modified: 2012-09-26 05:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 05:52:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (458 bytes, text/plain)
2012-09-25 14:52 EDT, Andres Cabrera
no flags Details

  None (edit)
Description Andres Cabrera 2012-09-25 14:51:55 EDT
Version-Release number of selected component:
system-config-printer-1.3.9-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
kernel:         3.5.4-1.fc17.x86_64

backtrace:
:newprinter.py:1690:start_fetching_devices:AttributeError: 'NewPrinterGUI' object has no attribute 'current_uri'
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 586, in msg_reply_handler
:    reply_handler(*message.get_args_list(**get_args_opts))
:  File "/usr/share/system-config-printer/firewall.py", line 86, in reply_handler
:    self._client_reply_handler (self._fw_data)
:  File "/usr/share/system-config-printer/newprinter.py", line 1676, in on_firewall_read
:    self.start_fetching_devices ()
:  File "/usr/share/system-config-printer/newprinter.py", line 1690, in start_fetching_devices
:    self.fetchDevices (network=False, current_uri=self.current_uri)
:AttributeError: 'NewPrinterGUI' object has no attribute 'current_uri'
:
:Local variables in innermost frame:
:self: <NewPrinterGUI object at 0x2f70640 (newprinter+NewPrinterGUI at 0x33ff2e0)>
Comment 1 Andres Cabrera 2012-09-25 14:52:00 EDT
Created attachment 617216 [details]
File: core_backtrace
Comment 2 Jiri Popelka 2012-09-26 05:52:31 EDT

*** This bug has been marked as a duplicate of bug 743717 ***

Note You need to log in before you can comment on or make changes to this bug.