Bug 860469 - RHEL6.4 python import distutils.version returns ValueError: bad marshal data
RHEL6.4 python import distutils.version returns ValueError: bad marshal data
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dave Malcolm
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 17:55 EDT by Scott Poore
Modified: 2012-09-26 15:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 15:12:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2012-09-25 17:55:10 EDT
Description of problem:

Seeing an error with python importing distutils.version.

[root@vm1 lib]# python
Python 2.6.6 (r266:84292, Aug 28 2012, 10:55:56) 
[GCC 4.4.6 20120305 (Red Hat 4.4.6-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import distutils.version
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ValueError: bad marshal data


Version-Release number of selected component (if applicable):
python-2.6.6-29.el6_3.3.x86_64 
from nightly RHEL6.4 test repo RHEL6.4-20120925.n.0


How reproducible:
seems very reproducible at the moment but not entirely known yet.


Steps to Reproduce:
1.  run python in interactive mode
python
2.  at prompt enter import distutils.version
>>>> import distutils.version

  
Actual results:

returns error listed above.

Expected results:

no error returned.

Additional info:
Comment 2 Scott Poore 2012-09-25 18:32:06 EDT
A reboot of my KVM guest where I saw this appears to have resolved the issue:

[root@vm1 ~]# python
Python 2.6.6 (r266:84292, Aug 28 2012, 10:55:56) 
[GCC 4.4.6 20120305 (Red Hat 4.4.6-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import distutils.version
>>> quit()

So, I'm not sure what happened there or how reproducible it is.
Comment 3 Dave Malcolm 2012-09-25 20:54:24 EDT
"bad marshal data" suggests a corrupt .pyc or .pyo file; given what you were importing, it sounds like:
  /usr/lib64/python2.6/distutils/version.pyc
was corrupt.  What does rpm -V say?

Maybe an issue at the virtualization level?
Comment 4 Scott Poore 2012-09-26 15:12:47 EDT
A corruption issue makes sense.  I thought I ran rpm -V python yesterday and didn't see anything.  Maybe that was after the reboot though.

I wasn't able to reproduce on another guest that was a clone of the same original.  And after the reboot it worked fine.  So, yeah, maybe an issue at the virtualization level like you're thinking.

I'm just going to close this one as NOTABUG since it looks like it's corruption and not reproducible.

Thanks for the info.

Note You need to log in before you can comment on or make changes to this bug.