Bug 860474 - UI for Layered Products is Prone to easy data loss
UI for Layered Products is Prone to easy data loss
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 18:24 EDT by John Poelstra
Modified: 2014-10-12 18:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 18:49:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2012-09-25 18:24:49 EDT
Description of problem:

The interface to selected layered products should be changed to check-box fields  like the privacy groups(or another mechanism) so that data is not unintentionally lost. 

One accidental click on a product that is not currently selected removes the current selections and you have no way to know what they were except by looking at the bug history (bad user experience).  If save is clicked without realizing this has happened, the previous selections, and a layered product could easily be dropped.

This is particularly bad because you cannot see all the entries at once because the list scrolls out of view so it is not possible to know which products are selected or not at a first glance.

Control click is bad way to provide multiple selection, particularly when you cannot see all the entries at once.
Comment 1 Simon Green 2012-09-25 18:31:11 EDT
If we turned all the multi select drop downs into checkboxes, the page would be too long.

  -- simon
Comment 2 John Poelstra 2012-09-25 18:37:20 EDT
Is another way to solve the problem and give a fair hearing to this issue?
Comment 3 Simon Green 2012-09-25 18:49:10 EDT
(In reply to comment #2)
> Is another way to solve the problem and give a fair hearing to this issue?

There is a change in an upcoming Bugzilla release to make it like the partner field (on page load it will contain a list of current values, and you click on edit to bring the drop down). This will highlight if any current values exist.

I cannot think of any other viable alternative. Having checkboxes in a drop down (for example http://code.google.com/p/dropdown-check-list/ ) isn't a good alternative IMO.
Comment 4 Jeff Fearn 2012-09-25 18:56:42 EDT
Hi John, can you explain to those of us not in the know what the impact is if a layered product is lost?
Comment 5 John Poelstra 2012-09-26 16:51:42 EDT
(In reply to comment #4)
> Hi John, can you explain to those of us not in the know what the impact is
> if a layered product is lost?

Data loss.  We loose meta data for other products that depend on a bug fix.
Comment 6 John Poelstra 2012-09-26 16:52:42 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > Is another way to solve the problem and give a fair hearing to this issue?
> 
> There is a change in an upcoming Bugzilla release to make it like the
> partner field (on page load it will contain a list of current values, and
> you click on edit to bring the drop down). This will highlight if any
> current values exist.
> 
> I cannot think of any other viable alternative. Having checkboxes in a drop
> down (for example http://code.google.com/p/dropdown-check-list/ ) isn't a
> good alternative IMO.

This is helpful information that would have been nice to have when this bug was first summarily closed.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.