Bug 860491 - yum OSError: [Errno 22] Invalid argument: '/var/lib/yum/yumdb/l/bcf2ac904fce487b48260b562eaca4677bcb0292-libsndfile-1.0.25-1.fc16-x86_64/checksum_type'
yum OSError: [Errno 22] Invalid argument: '/var/lib/yum/yumdb/l/bcf2ac904fce4...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-25 20:46 EDT by Phil V
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 15:53:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil V 2012-09-25 20:46:30 EDT
Description of problem:

Recently (last two weeks or so) yum update fails. always. Even after yum clean all.

Version-Release number of selected component (if applicable):
yum --version
3.4.3
  Installed: rpm-4.9.1.3-1.fc16.x86_64 at 2012-04-26 02:57
  Built    : Fedora Project at 2012-04-03 15:49
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-04-03

  Installed: yum-3.4.3-25.fc16.noarch at 2012-08-09 20:48
  Built    : Fedora Project at 2012-08-01 15:48
  Committed: Zdenek Pavlas <zpavlas at redhat.com> at 2012-08-01

  Installed: yum-plugin-fastestmirror-1.1.31-2.fc16.noarch at 2011-12-21 21:59
  Built    : Fedora Project at 2011-08-13 14:09
  Committed: Tim Lauridsen <timlau@fedoraproject.org> at 2011-08-13

I have tried yum update package eg:


# yum update fire*
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, remove-with-leaves, show-leaves
Loading mirror speeds from cached hostfile
 * fedora: fedora.mirror.lstn.net
 * rpmfusion-free: mirror.us.leaseweb.net
 * rpmfusion-free-updates: mirror.us.leaseweb.net
 * rpmfusion-nonfree: mirror.us.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.us.leaseweb.net
 * updates: fedora.mirror.lstn.net
Resolving Dependencies
--> Running transaction check
---> Package firefox.x86_64 0:15.0-1.fc16 will be updated
---> Package firefox.x86_64 0:15.0.1-1.fc16 will be an update
--> Processing Dependency: xulrunner(x86-64) >= 15.0.1-1 for package: firefox-15.0.1-1.fc16.x86_64
--> Running transaction check
---> Package xulrunner.x86_64 0:15.0-2.fc16 will be updated
---> Package xulrunner.x86_64 0:15.0.1-1.fc16 will be an update
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 321, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 187, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1114, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 864, in resolveDeps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 1144, in _checkFileRequires
    self.installedFileProviders = self.rpmdb.fileRequiresData()
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 902, in fileRequiresData
    rpmdbv = self.simpleVersion(main_only=True)[0]
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1136, in simpleVersion
    if 'checksum_type' in ydbi and 'checksum_data' in ydbi:
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1825, in __contains__
    x = self.get(attr)
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1855, in get
    res = self._read(attr)
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1770, in _read
    info = misc.stat_f(fn, ignore_EACCES=True)
  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 958, in stat_f
    return os.stat(filename)
OSError: [Errno 22] Invalid argument: '/var/lib/yum/yumdb/l/bcf2ac904fce487b48260b562eaca4677bcb0292-libsndfile-1.0.25-1.fc16-x86_64/checksum_type'
Comment 1 Zdeněk Pavlas 2012-09-26 08:42:54 EDT
This is weird, as both os.stat() and stat(2) are documented NOT to return EINVAL.
What does "stat /var/lib/yum/yumdb/l/bcf2ac904fce487b48260b562eaca4677bcb0292-libsndfile-1.0.25-1.fc16-x86_64/checksum_type" say?  Have you tried running fsck?
Comment 2 Phil V 2012-10-05 17:51:24 EDT
Good catch. Rebooting off a Live USB drive and then running xfs_repair removed this error. 

Alas, yum verify all reports a bunch of errors, that 'yum reinstall' X does not seem to solve.
Comment 3 Fedora End Of Life 2013-01-16 11:50:48 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora End Of Life 2013-02-13 15:53:41 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.