Bug 860623 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the file P1030217.JPG.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' acc...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1c2ebb86d4e22f3e66c417839bc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 06:32 EDT by Frank Büttner
Modified: 2012-10-01 11:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-01 11:02:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-26 06:32 EDT, Frank Büttner
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-26 06:32 EDT, Frank Büttner
no flags Details

  None (edit)
Description Frank Büttner 2012-09-26 06:32:30 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.5.4-1.fc17.x86_64

description:
:This happends when I upload pictures from an smb share to an website that use flash for the upload process.
:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'read' accesses on the file P1030217.JPG.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If sie denken, dass plugin-container standardmässig erlaubt sein sollte, read Zugriff auf P1030217.JPG file zu erhalten.
:Then sie sollten dies als Fehler melden.
:Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
:Do
:zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:fusefs_t:s0
:Target Objects                P1030217.JPG [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           xulrunner-15.0.1-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-149.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.4-1.fc17.x86_64 #1 SMP Mon Sep
:                              17 15:03:59 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-09-26 12:29:28 CEST
:Last Seen                     2012-09-26 12:29:34 CEST
:Local ID                      f62b1799-db8c-4812-891b-f92f16e07f97
:
:Raw Audit Messages
:type=AVC msg=audit(1348655374.545:263): avc:  denied  { read } for  pid=8706 comm="plugin-containe" name="P1030217.JPG" dev="fuse" ino=17 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fusefs_t:s0 tclass=file
:
:
:type=AVC msg=audit(1348655374.545:263): avc:  denied  { open } for  pid=8706 comm="plugin-containe" path=2F72756E2F757365722F6672616E6B2F677666732F6672616E6B2061756620686F6D65722F42696C6465722F4672616E6B27732042696C6465722F49636820616D204B6F6368656E2F5A6974726F6E656E6B756368656E2F50313033303231372E4A5047 dev="fuse" ino=17 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fusefs_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1348655374.545:263): arch=x86_64 syscall=open success=yes exit=EFBIG a0=7f95141d4ee0 a1=0 a2=1b6 a3=0 items=0 ppid=2793 pid=8706 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=4 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,fusefs_t,file,read
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:#!!!! This avc can be allowed using the boolean 'use_fusefs_home_dirs'
:
:allow mozilla_plugin_t fusefs_t:file { read open };
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:#!!!! This avc can be allowed using the boolean 'use_fusefs_home_dirs'
:
:allow mozilla_plugin_t fusefs_t:file { read open };
:
Comment 1 Frank Büttner 2012-09-26 06:32:33 EDT
Created attachment 617493 [details]
File: type
Comment 2 Frank Büttner 2012-09-26 06:32:36 EDT
Created attachment 617494 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-26 07:38:55 EDT
You need to execute

# setsebool -P use_fusefs_home_dirs 1


to make this working.
Comment 4 Frank Büttner 2012-09-28 07:28:45 EDT
Hello,
I have try it without the "P" option to test it.
But then I get the next warning:

Raw Audit Messages
type=AVC msg=audit(1348831490.920:235): avc:  denied  { getattr } for  pid=6459 comm="pool" path="/home/frank/Kalender/frank.tar" dev="cifs" ino=13978488 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cifs_t:s0 tclass=file


type=SYSCALL msg=audit(1348831490.920:235): arch=x86_64 syscall=lstat success=yes exit=0 a0=7f3b986621e0 a1=7f3b8ecb7950 a2=7f3b8ecb7950 a3=7f3bacb111b8 items=0 ppid=2755 pid=6459 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=3 comm=pool exe=2F7573722F6C696236342F78756C72756E6E65722D322F706C7567696E2D636F6E7461696E65722E237072656C696E6B232E6F4F31384671202864656C6574656429 subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: pool,mozilla_plugin_t,cifs_t,file,getattr

audit2allow

#============= mozilla_plugin_t ==============
#!!!! This avc can be allowed using the boolean 'use_samba_home_dirs'

allow mozilla_plugin_t cifs_t:file getattr;

audit2allow -R

#============= mozilla_plugin_t ==============
#!!!! This avc can be allowed using the boolean 'use_samba_home_dirs'

allow mozilla_plugin_t cifs_t:file getattr;



Exits here also an boolean?
Comment 5 Daniel Walsh 2012-10-01 10:51:14 EDT
That is because you have a cifs home dir not a fuse one.

setsebool -P use_samba_home_dirs 1
Comment 6 Frank Büttner 2012-10-01 11:02:07 EDT
Yes, now it will work.
But I need both:
setsebool -P use_fusefs_home_dirs 1 and
setsebool -P use_samba_home_dirs 1

So I close the bug now.
Thanks for help.

Note You need to log in before you can comment on or make changes to this bug.