Bug 860693 - --details option for searching RPMs displays nothing
--details option for searching RPMs displays nothing
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 42
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
: 873450 (view as bug list)
Depends On: 844751
Blocks: 873419
  Show dependency treegraph
 
Reported: 2012-09-26 09:55 EDT by Jay Dobies
Modified: 2013-09-09 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 873419 (view as bug list)
Environment:
Last Closed: 2012-11-19 16:26:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2012-09-26 09:55:16 EDT
Part of the change to remove the metadata snippets from the RPMs when displaying them didn't take into account the --details view which displays association metadata.

I'm in the middle of a bunch of refactors in the RPM extensions and don't have time to fully do a clean job in this module. It should probably be readdressed across the board, so instead of adding a hack to fix this, this bug should be to clean up that module entirely and fix this in the process.
Comment 1 Michael Hrivnak 2012-10-16 14:08:32 EDT
Discussing this with jdob, we are going to punt this until sprint 42 and combine it with the effort to make the CLI behave "quietly" or in a manner that produces more machine-friendly output.
Comment 2 Jay Dobies 2012-11-05 17:37:14 EST
*** Bug 873450 has been marked as a duplicate of this bug. ***
Comment 3 Michael Hrivnak 2012-11-19 10:00:48 EST
Due to an accelerated release schedule of Pulp 2.0, the "quiet" CLI behavior will not actually be part of this fix, but will come at a later date.

Note You need to log in before you can comment on or make changes to this bug.